aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-12-24 17:47:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:40:10 +0000
commit9f3e6d811d9a360dc41031838431edcd2e226f3d (patch)
treea299175983a5e093bc2f8529708749e7201c0c2c
parentb600adb4297798f108cb38d8ad7581bc517ae56b (diff)
downloadopenembedded-core-contrib-9f3e6d811d9a360dc41031838431edcd2e226f3d.tar.gz
gccmakedep: fix buildpaths qa check
When enable "buildpaths" QA check, it fails to build gccmakedep: | ERROR: QA Issue: File | work/mips64-poky-linux/gccmakedep/1_1.0.3-r3/packages-split/gccmakedep/usr/bin/gccmakedep | in package contained reference to tmpdir [buildpaths] Remove build related path to fix this issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/xorg-util/gccmakedep_1.0.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-util/gccmakedep_1.0.3.bb b/meta/recipes-graphics/xorg-util/gccmakedep_1.0.3.bb
index ccf2f4b451..be3a667449 100644
--- a/meta/recipes-graphics/xorg-util/gccmakedep_1.0.3.bb
+++ b/meta/recipes-graphics/xorg-util/gccmakedep_1.0.3.bb
@@ -14,4 +14,8 @@ PR = "r3"
PE = "1"
SRC_URI[md5sum] = "127ddb6131eb4a56fdf6644a63ade788"
-SRC_URI[sha256sum] = "f9e2e7a590e27f84b6708ab7a81e546399b949bf652fb9b95193e0e543e6a548" \ No newline at end of file
+SRC_URI[sha256sum] = "f9e2e7a590e27f84b6708ab7a81e546399b949bf652fb9b95193e0e543e6a548"
+
+do_install_append() {
+ sed -i "s,--sysroot=${STAGING_DIR_TARGET},," ${D}${bindir}/gccmakedep
+}