aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-09-04 18:20:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-08 00:31:34 +0100
commitf3a50f89a217014c0926498e99e62c617a8a4cae (patch)
treef8b1de00d849d5fa4d98f270a32a2369d29be53f
parent3d4834860c0e9c2635c248d498d02160cbedebde (diff)
downloadopenembedded-core-contrib-f3a50f89a217014c0926498e99e62c617a8a4cae.tar.gz
libcap: Replace EXTRA_OECONF with PACKAGECONFIG_CONFARGS
When building libcap and DISTRO_FEATURES does not contain pam, the build will fail on missing pam headers. This is because the bits from EXTRA_OECONF moved to PACKAGECONFIG_CONFARGS and thus the necessary options are not propagated to oe_runmake anymore. Replace EXTRA_OECONF with PACKAGECONFIG_CONFARGS to fix this. | arm-poky-linux-gnueabi-gcc -march=armv7-a -mfpu=vfp -mfloat-abi=softfp --sysroot=/b/tmp/sysroots/board -O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/b/tmp/work/armv7a-vfp-poky-linux-gnueabi/libcap/2.25-r0=/usr/src/debug/libcap/2.25-r0 -fdebug-prefix-map=/b/tmp/sysroots/x86_64-linux= -fdebug-prefix-map=/b/tmp/sysroots/board= -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Dlinux -Wall -Wwrite-strings -Wpointer-arith -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wshadow -g -Dlinux -Wall -Wwrite-strings -Wpointer-arith -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wshadow -g -fPIC -I/b/tmp/work/armv7a-vfp-poky-linux-gnueabi/libcap/2.25-r0/libcap-2.25/pam_cap/../libcap/include/uapi -I/b/tmp/work/armv7a-vfp-poky-linux-gnueabi/libcap/2.25-r0/libcap-2.25/pam_cap/../libcap/include -c pam_cap.c -o pam_cap.o | pam_cap.c:19:34: fatal error: security/pam_modules.h: No such file or directory | #include <security/pam_modules.h> | ^ | compilation terminated. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libcap/libcap_2.25.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.25.bb b/meta/recipes-support/libcap/libcap_2.25.bb
index 8f3f11e5e6..7ced4be626 100644
--- a/meta/recipes-support/libcap/libcap_2.25.bb
+++ b/meta/recipes-support/libcap/libcap_2.25.bb
@@ -47,12 +47,12 @@ EXTRA_OEMAKE_append_class-target = " SYSTEM_HEADERS=${STAGING_INCDIR}"
CFLAGS += "-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
do_compile() {
- oe_runmake ${EXTRA_OECONF}
+ oe_runmake ${PACKAGECONFIG_CONFARGS}
}
do_install() {
oe_runmake install \
- ${EXTRA_OECONF} \
+ ${PACKAGECONFIG_CONFARGS} \
DESTDIR="${D}" \
prefix="${prefix}" \
SBINDIR="${sbindir}"