aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Donnelly <martin.donnelly@ge.com>2016-02-22 19:32:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-26 17:15:07 +0000
commite46eae34ac71d28aa92feed369c2d92248ed3e19 (patch)
tree71a17321f72c5fd86b5a4ab5feee6823eaade537
parente9b44579007cbaa24c6b39ff788be3a927797660 (diff)
downloadopenembedded-core-contrib-e46eae34ac71d28aa92feed369c2d92248ed3e19.tar.gz
perf: add sysroot handling to subcmd
v4.5-rc1 of the kernel splits the subcommand related files from perf into a new library, this patch adds the modification of the Makefile to preserve the --sysroot option as for the other perf related Makefiles. Signed-off-by: Martin Donnelly <martin.donnelly@ge.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 33acb42712..8b86290201 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -164,6 +164,10 @@ do_configure_prepend () {
sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
fi
+ if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
+ sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
+ sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
+ fi
if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
fi