aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2016-03-23 11:09:18 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-28 15:54:51 +0100
commitb81c176fb2f1ee818b6049c39ef353a7d7d5e078 (patch)
tree68c33ca15ae94a67b3277321a6c43ddfc348e7fd
parentd483724cf3515f76e1b798a2018e2f3fa2bad0ba (diff)
downloadopenembedded-core-contrib-b81c176fb2f1ee818b6049c39ef353a7d7d5e078.tar.gz
image.bbclass: run wicenv task only for wic images
Currently do_wicenv task is run for all images. However, its result is used only to produce wic image. It's better to run this task only for wic images. If another rootfs is required to produce wic image, dependency to its do_wicenv must be added to the wic image recipy. Stopped running do_wicenv for all images. Added explicit dependency to this task in wic-image-minimal recipe. [YOCTO #9095] Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.bb2
-rw-r--r--meta/classes/image.bbclass2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.bb b/meta-selftest/recipes-test/images/wic-image-minimal.bb
index 9c50ddbbf5..a294ba7af4 100644
--- a/meta-selftest/recipes-test/images/wic-image-minimal.bb
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.bb
@@ -11,7 +11,7 @@ DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-nativ
# core-image-minimal is referenced in .wks, so we need its rootfs
# to be ready before our rootfs
-do_rootfs[depends] += "core-image-minimal:do_rootfs_wicenv"
+do_rootfs[depends] += "core-image-minimal:do_image core-image-minimal:do_rootfs_wicenv"
IMAGE_ROOTFS_EXTRA_SPACE = "2000"
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 0249f77bcf..62ff07e2e7 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -275,7 +275,7 @@ python do_rootfs_wicenv () {
if value:
envf.write('%s="%s"\n' % (var, value.strip()))
}
-addtask do_rootfs_wicenv after do_image before do_image_wic do_image_complete
+addtask do_rootfs_wicenv after do_image before do_image_wic
do_rootfs_wicenv[vardeps] += "${WICVARS}"
do_rootfs_wicenv[prefuncs] = 'set_image_size'