aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-02-10 21:13:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 22:32:17 +0000
commit1348fe26a182330475ca163e87205dc162fb3f6a (patch)
tree968ae90edbcd5297cb6415955864dfc75b8e9f44
parent33b5c3b4822b6bbb06ad5fdf7a120acd520f665d (diff)
downloadopenembedded-core-contrib-1348fe26a182330475ca163e87205dc162fb3f6a.tar.gz
python-setuptools: Add python-compile on RDEPENDS
When trying to install packages using python-setuptools, compilation may fail complaining about the py_compile module not existing, this presented itself when installing pyephem for example, this patch adds python-compile to setuptools RDEPENDS to fix the issue. [YOCTO 9009] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-setuptools_19.4.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_19.4.bb b/meta/recipes-devtools/python/python-setuptools_19.4.bb
index 86bbebf081..c172039231 100644
--- a/meta/recipes-devtools/python/python-setuptools_19.4.bb
+++ b/meta/recipes-devtools/python/python-setuptools_19.4.bb
@@ -23,6 +23,7 @@ RDEPENDS_${PN} = "\
python-ctypes \
python-subprocess \
python-unittest \
+ python-compile \
"
RDEPENDS_${PN}_class-native = "\