aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-02-20 16:56:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 12:29:17 -0800
commitdcf582f8f210c8e9d46f96950d48743819b87f9a (patch)
treef24bc7acae1ff5ec4d0edc55a84344c13783cf83
parentcde7b38bcbd419799070da92013b4ea98468e643 (diff)
downloadopenembedded-core-contrib-dcf582f8f210c8e9d46f96950d48743819b87f9a.tar.gz
unifdef: add UPSTREAM_CHECK_REGEX to filter out development snapshots
Upstream is releasing development snapshots of the form unifdef-2.11.23.1cca442.tar.gz so filter out versions which end is something that looks like a git SHA. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/unifdef/unifdef_2.11.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unifdef/unifdef_2.11.bb b/meta/recipes-devtools/unifdef/unifdef_2.11.bb
index 1d13b9a6bf..1ffc11e76b 100644
--- a/meta/recipes-devtools/unifdef/unifdef_2.11.bb
+++ b/meta/recipes-devtools/unifdef/unifdef_2.11.bb
@@ -10,6 +10,8 @@ SRC_URI = "http://dotat.at/prog/${BPN}/${BP}.tar.xz"
SRC_URI[md5sum] = "337053fd8a7d9ab3adf5e50f88af95b7"
SRC_URI[sha256sum] = "828ffc270ac262b88fe011136acef2780c05b0dc3c5435d005651740788d4537"
+UPSTREAM_CHECK_REGEX = "unifdef-(?P<pver>((\d+\.*)+)(?![a-f0-9]{6,})).tar"
+
do_install() {
oe_runmake install DESTDIR=${D} prefix=${prefix}
}