aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2017-02-15 09:13:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 12:29:19 -0800
commitdc549b5510bfcf83f6e5e8e3aa7ed663dee83444 (patch)
treea14a4750f0aa03cf60c643030797316d582a5002
parent9b036ac92073cadd26819def37ac0199f1ec9934 (diff)
downloadopenembedded-core-contrib-dc549b5510bfcf83f6e5e8e3aa7ed663dee83444.tar.gz
openembedded-core-contrib-dc549b5510bfcf83f6e5e8e3aa7ed663dee83444.tar.bz2
openembedded-core-contrib-dc549b5510bfcf83f6e5e8e3aa7ed663dee83444.zip
alsa-lib: 1.1.2 -> 1.1.3
Changelog: http://alsa-project.org/main/index.php/Changes_v1.1.2_v1.1.3 Added a patch to fix a build failure with musl (cherry-picked from upstream). The new release doesn't any more install the smixer modules when Python support is disabled. The modules weren't usable without Python support before either, so this change does not constitute a loss of functionality [1]. alsa-lib-dev has automatic dependencies on alsa-lib and libasound, but since the smixer modules were the only thing in the alsa-lib package, the alsa-lib package doesn't get generated any more. alsa-lib-dev still has an automatic dependency on alsa-lib, however, so I had to override the RDEPENDS of alsa-lib-dev to only include libasound. [1] http://mailman.alsa-project.org/pipermail/alsa-devel/2016-November/114682.html Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib/0001-ucm-parser-needs-limits.h.patch33
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.1.3.bb (renamed from meta/recipes-multimedia/alsa/alsa-lib_1.1.2.bb)12
2 files changed, 41 insertions, 4 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib/0001-ucm-parser-needs-limits.h.patch b/meta/recipes-multimedia/alsa/alsa-lib/0001-ucm-parser-needs-limits.h.patch
new file mode 100644
index 00000000000..4edaf4d9612
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib/0001-ucm-parser-needs-limits.h.patch
@@ -0,0 +1,33 @@
+From 005ac9d2fa000912c8fb8257020a0471b1c6176c Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Wed, 21 Dec 2016 19:46:34 -0300
+Subject: [PATCH] ucm: parser needs limits.h
+
+It's using PATH_MAX which is defined there, otherwise the build fails on
+musl libc.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Signed-off-by: Takashi Iwai <tiwai@suse.de>
+
+Upstream-Status: Accepted [expected in 1.1.4]
+
+Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
+---
+ src/ucm/parser.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/ucm/parser.c b/src/ucm/parser.c
+index c98373a9..f520abc5 100644
+--- a/src/ucm/parser.c
++++ b/src/ucm/parser.c
+@@ -32,6 +32,7 @@
+
+ #include "ucm_local.h"
+ #include <dirent.h>
++#include <limits.h>
+
+ /** The name of the environment variable containing the UCM directory */
+ #define ALSA_CONFIG_UCM_VAR "ALSA_CONFIG_UCM"
+--
+2.11.0
+
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.1.2.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.1.3.bb
index e313da78e4d..5c213bebde1 100644
--- a/meta/recipes-multimedia/alsa/alsa-lib_1.1.2.bb
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.1.3.bb
@@ -11,9 +11,10 @@ BBCLASSEXTEND = "native nativesdk"
SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2 \
file://Check-if-wordexp-function-is-supported.patch \
file://avoid-including-sys-poll.h-directly.patch \
+ file://0001-ucm-parser-needs-limits.h.patch \
"
-SRC_URI[md5sum] = "1946e6438b8262a7b8fdadacd0e06ba7"
-SRC_URI[sha256sum] = "d38dacd9892b06b8bff04923c380b38fb2e379ee5538935ff37e45b395d861d6"
+SRC_URI[md5sum] = "eefe5992567ba00d6110a540657aaf5c"
+SRC_URI[sha256sum] = "71282502184c592c1a008e256c22ed0ba5728ca65e05273ceb480c70f515969c"
inherit autotools pkgconfig
@@ -25,8 +26,6 @@ EXTRA_OECONF = "--disable-python"
EXTRA_OECONF_append_libc-uclibc = " --with-versioned=no "
PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc"
-FILES_${PN} += "${libdir}/${BPN}/smixer/*.so"
-FILES_${PN}-dev += "${libdir}/${BPN}/smixer/*.la"
FILES_libasound = "${libdir}/libasound.so.*"
FILES_alsa-server = "${bindir}/*"
FILES_alsa-conf = "${datadir}/alsa/"
@@ -38,6 +37,11 @@ ${datadir}/alsa/pcm/dmix.conf \
${datadir}/alsa/pcm/dsnoop.conf"
RDEPENDS_libasound = "alsa-conf-base alsa-conf"
+
+# alsa-lib gets automatically added to alsa-lib-dev dependencies, but the
+# alsa-lib package doesn't exist. libasound is the real library package.
+RDEPENDS_${PN}-dev = "libasound"
+
# upgrade path
RPROVIDES_${PN}-dev = "alsa-dev"
RREPLACES_${PN}-dev = "alsa-dev"