aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-02-14 22:25:10 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 12:29:16 -0800
commit68960cbdf12de8aaff0f792091f839c987cc0aa0 (patch)
treebde1fd406db5bda4b057918ffee02abd64bb3dd6
parent84f254cb8c75fbd368041b7637effe42a05b2203 (diff)
downloadopenembedded-core-contrib-68960cbdf12de8aaff0f792091f839c987cc0aa0.tar.gz
tcl: fix sed in do_install()
The command: sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh was used for replacing "${WORKDIR}", but it also replaced "-L${WORKDIR}", but binconfig.bbclass would replace "-L${WORKDIR}", too, which caused incorrect result, use "'${WORKDIR}" to fix the problem. (From OE-Core rev: 2edfcbf0291c0d39be4a37348696329eba8a41f8) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.6.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
index c828b38772..40cd18fb09 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
@@ -55,7 +55,7 @@ do_install() {
ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER}
sed -i "s;-L${B};-L${STAGING_LIBDIR};g" tclConfig.sh
- sed -i "s;${WORKDIR};${STAGING_INCDIR};g" tclConfig.sh
+ sed -i "s;'${WORKDIR};'${STAGING_INCDIR};g" tclConfig.sh
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${libdir}