aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-02-17 16:58:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 12:29:17 -0800
commit0e3a933c376b3bdb46bd3a2993932888ecfde434 (patch)
tree76b10ed41eacb5736dfd7e057abe837bc0538cea
parent42c32a9c8e3ca28e553a3b95089e0d51390c1758 (diff)
downloadopenembedded-core-contrib-0e3a933c376b3bdb46bd3a2993932888ecfde434.tar.gz
btrfs-tools: don't run autogen.sh
Instead of running autogen.sh (which runs autoconf et al) before running autoreconf (which runs autoreconf et al...) just do the one task that we need from autogen.sh: copying install-sh from automake's libdir. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.8.5.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.8.5.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.8.5.bb
index 7047c43402..04e1e6195c 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.8.5.bb
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.8.5.bb
@@ -14,17 +14,17 @@ DEPENDS = "util-linux attr e2fsprogs lzo acl udev"
RDEPENDS_${PN} = "libgcc"
SRCREV = "144a19145e248513c7a676defad59836830535c6"
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
-"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
inherit autotools-brokensep pkgconfig manpages
PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
-
do_configure_prepend() {
- sh autogen.sh
+ # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
+ mkdir -p ${S}/config
+ cp -f $(automake --print-libdir)/install-sh ${S}/config/
}
S = "${WORKDIR}/git"