summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-08-30 15:37:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-30 22:30:23 +0100
commit6e1fc83e7d7285211ae24e38b8fa7fbe7112d126 (patch)
tree32aeb1f246ce069169024329112dc1ad76618dcd
parent9b404c24ddc6212576b78c9fc56c57baa0fb3745 (diff)
downloadopenembedded-core-contrib-6e1fc83e7d7285211ae24e38b8fa7fbe7112d126.tar.gz
avahi-ui: support usrmerge
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/avahi/avahi-ui_0.7.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/avahi/avahi-ui_0.7.bb b/meta/recipes-connectivity/avahi/avahi-ui_0.7.bb
index a77653bf55..1c6e46aaba 100644
--- a/meta/recipes-connectivity/avahi/avahi-ui_0.7.bb
+++ b/meta/recipes-connectivity/avahi/avahi-ui_0.7.bb
@@ -20,7 +20,13 @@ FILES_avahi-discover = "${datadir}/applications/avahi-discover.desktop \
do_install_append () {
rm ${D}${sysconfdir} -rf
- rm ${D}${base_libdir} -rf
+ if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+ if [ "${nonarch_base_libdir}" != "${base_libdir}" ];then
+ rm ${D}${nonarch_base_libdir} -rf
+ fi
+ else
+ rm ${D}${base_libdir} -rf
+ fi
rm ${D}${systemd_unitdir} -rf
# The ${systemd_unitdir} is /lib/systemd, so we need rmdir /lib,
# but not ${base_libdir} here. And the /lib may not exist