summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2019-08-23 16:56:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-30 17:10:23 +0100
commit2c36b3e5c7caae07ffe0cfb816d37fad52d69fc9 (patch)
tree91de9c6d68be4e512fca1cc2945c860f5758523f
parent9b3134995cf054679d573f28f916a629332ce126 (diff)
downloadopenembedded-core-contrib-2c36b3e5c7caae07ffe0cfb816d37fad52d69fc9.tar.gz
bind: fix build with python3 PACKAGECONFIG enabled
If the PACKAGECONFIG item, python3, is enabled, we get the following QA issue when multilib is enabled. ERROR: bind-9.11.5-P4-r0 do_package: QA Issue: bind: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/python3.7 /usr/lib/python3.7/site-packages /usr/lib/python3.7/site-packages/isc-2.0-py3.7.egg-info /usr/lib/python3.7/site-packages/isc /usr/lib/python3.7/site-packages/isc/policy.py [snip] The thing is, when --with-python is specified with a path instead of 'yes', the --with-python-install-dir is in fact ignored. Fix this issue by specifying the correct arguments. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/bind/bind_9.11.5-P4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.11.5-P4.bb b/meta/recipes-connectivity/bind/bind_9.11.5-P4.bb
index 93c406f778..69b1174073 100644
--- a/meta/recipes-connectivity/bind/bind_9.11.5-P4.bb
+++ b/meta/recipes-connectivity/bind/bind_9.11.5-P4.bb
@@ -39,7 +39,7 @@ PACKAGECONFIG[httpstats] = "--with-libxml2=${STAGING_DIR_HOST}${prefix},--withou
PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline"
PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit"
PACKAGECONFIG[urandom] = "--with-randomdev=/dev/urandom,--with-randomdev=/dev/random,,"
-PACKAGECONFIG[python3] = "--with-python=${PYTHON} --with-python-install-dir=${D}/${PYTHON_SITEPACKAGES_DIR} , --without-python, python3-ply-native,"
+PACKAGECONFIG[python3] = "--with-python=yes --with-python-install-dir=${PYTHON_SITEPACKAGES_DIR} , --without-python, python3-ply-native,"
ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}"
EXTRA_OECONF = " ${ENABLE_IPV6} --with-libtool --enable-threads \