aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-10-06 18:29:16 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-09 12:02:41 +0100
commit4015f3279aaced1c5d9ae8a6e666c9fba42558df (patch)
treec8204e958e5a77c1b72232e5ce81f8fc1fe31a17
parentbfd32c0d1c335e9c9cf8340f999e15054917577e (diff)
downloadopenembedded-core-contrib-4015f3279aaced1c5d9ae8a6e666c9fba42558df.tar.gz
ffmpeg: use bfd linker always for x86 target
gold crashes when linking, so use bfd linker here, another option is to use --disable-asm but then we loose performance. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_4.0.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_4.0.2.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_4.0.2.bb
index 58f58fc5c8..7d1af04047 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_4.0.2.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_4.0.2.bb
@@ -117,6 +117,10 @@ EXTRA_OECONF = " \
"
EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"
+# gold crashes on x86, another solution is to --disable-asm but thats more hacky
+# ld.gold: internal error in relocate_section, at ../../gold/i386.cc:3684
+
+LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
do_configure() {
${S}/configure ${EXTRA_OECONF}