aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 09:15:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 11:26:26 +0100
commitfe6cabfb0c6f382ef6131e07437b90c2afbf5488 (patch)
tree4684005cb2d93867c2ba893d6d0ced8cfc139f33
parenta6d6432b508451d0847336dc980bc0541396e310 (diff)
downloadopenembedded-core-contrib-fe6cabfb0c6f382ef6131e07437b90c2afbf5488.tar.gz
libxml2/libxslt: Don't depend on ansidecl.h header
We don't DEPEND on binutils for ansidecl.h so ensure we should never use the header. This makes builds determinstic and means something like: bitbake binutils bitbake libxml2 -c configure bitbake binutils -c clean bitbake libxml2 doen't fail to build. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/libxml/libxml2.inc5
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.26.bb7
2 files changed, 11 insertions, 1 deletions
diff --git a/meta/recipes-core/libxml/libxml2.inc b/meta/recipes-core/libxml/libxml2.inc
index 2eecbd30e7..32d6e8cd31 100644
--- a/meta/recipes-core/libxml/libxml2.inc
+++ b/meta/recipes-core/libxml/libxml2.inc
@@ -18,6 +18,11 @@ SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
inherit autotools pkgconfig binconfig
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e '/.*ansidecl.h.*/d' ${S}/configure.in
+}
+
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"
EXTRA_OECONF_virtclass-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.26.bb b/meta/recipes-support/libxslt/libxslt_1.1.26.bb
index 8986e20723..e4cc21472b 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.26.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.26.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
SECTION = "libs"
DEPENDS = "libxml2"
-PR = "r7"
+PR = "r8"
SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
file://pkgconfig_fix.patch"
@@ -18,6 +18,11 @@ S = "${WORKDIR}/libxslt-${PV}"
inherit autotools pkgconfig binconfig lib_package
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e 's/ansidecl.h//' ${S}/configure.in
+}
+
EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
# older versions of this recipe had ${PN}-utils
RPROVIDES_${PN}-bin += "${PN}-utils"