aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-07 06:40:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 11:20:49 +0100
commitd56657cf5def88682954a97b4d94603ad81fd6e5 (patch)
treeea4df24a3388ae263340a68a727c1a13e6c3c4ff
parentfc1d2b4ec7e7f5c5e2b3434bc8208967ead6f336 (diff)
downloadopenembedded-core-contrib-d56657cf5def88682954a97b4d94603ad81fd6e5.tar.gz
trace-cmd: fix recompile error
Fixed: make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `parse-events.o'. Stop. make: *** Waiting for unfinished jobs.... ERROR: oe_runmake failed This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .parse-events.d isn't regenerated when recompile, the content of it are: [snip] parse-events.o: /path/to/sysroot/4.9.0/include/stddef.h [snip] And Makefile includes the .parse-events.d file if it exists, so there would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist. Remove .*.d (a few .d files, its Makefile uses this wildcard) will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb b/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
index 8d26205672..a4d5382aaf 100644
--- a/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
+++ b/meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb
@@ -30,6 +30,11 @@ EXTRA_OEMAKE = "\
FILES_${PN}-dbg += "${libdir}/trace-cmd/plugins/.debug"
+do_compile_prepend() {
+ # Make sure the recompile is OK
+ rm -f ${B}/.*.d
+}
+
do_install() {
oe_runmake DESTDIR="${D}" install
}