aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-08-24 15:34:35 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 13:04:38 +0100
commitcb73e943aa31a755abc20b9a4c221ca1b183f347 (patch)
tree4aba9a2755d0348ec585bf15ce6a163ee642d956
parent37f914dd72145a4e6ecc9ed75cbe27745670f499 (diff)
downloadopenembedded-core-contrib-cb73e943aa31a755abc20b9a4c221ca1b183f347.tar.gz
bash (GPLv2): remove metadata sharing from GPLv3 recipe
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
-rw-r--r--meta/packages/bash/bash_3.2.48.bb30
1 files changed, 27 insertions, 3 deletions
diff --git a/meta/packages/bash/bash_3.2.48.bb b/meta/packages/bash/bash_3.2.48.bb
index 47afe98801..ee563d626a 100644
--- a/meta/packages/bash/bash_3.2.48.bb
+++ b/meta/packages/bash/bash_3.2.48.bb
@@ -1,11 +1,35 @@
-require bash.inc
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+SECTION = "base/shell"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
+DEPENDS = "ncurses"
+
PR = "r6"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-050;apply=yes;striplevel=0 \
- http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-051;apply=yes;striplevel=0 \
- "
+ http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-051;apply=yes;striplevel=0"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+ gnu-configize
+ oe_runconf
+}
+
+pkg_postinst () {
+ touch $D${sysconfdir}/shells
+ grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
+ grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
+}