aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2012-01-04 22:30:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-05 22:19:15 +0000
commitc3400040fdce8c049b51a8acb06eb2e92f9426d1 (patch)
tree9ba7b15d636e0cfd707dad93d2b34d4d3856c9fa
parented937940f54d1a376b518fc276da78811c4ac50b (diff)
downloadopenembedded-core-contrib-c3400040fdce8c049b51a8acb06eb2e92f9426d1.tar.gz
matchbox-wm: Remove x-session-manager handling
Windows manager should be independent on session manager, especially when we have multiple session manager like mini-x and matchbox session. This commit remove session-manager stuff in matchbox-wm, as matchbox-session already has duplicated code. Also adjust alternative priority for mini-X to make it higher priority over matchbox-session. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb9
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb9
-rw-r--r--meta/recipes-graphics/mini-x-session/mini-x-session_0.1.bb2
3 files changed, 5 insertions, 15 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
index 84b966a743..26283266ae 100644
--- a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.bb
@@ -2,7 +2,7 @@ SECTION = "x11/wm"
DESCRIPTION = "Matchbox window manager"
LICENSE = "GPLv2.0+"
DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
file://configure_fix.patch \
@@ -11,7 +11,7 @@ SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/match
S = "${WORKDIR}/matchbox-window-manager-${PV}"
-inherit autotools pkgconfig update-alternatives
+inherit autotools pkgconfig
FILES_${PN} = "${bindir}/* \
${datadir}/matchbox \
@@ -20,11 +20,6 @@ FILES_${PN} = "${bindir}/* \
${datadir}/themes/Default/matchbox \
${datadir}/themes/MBOpus/matchbox"
-ALTERNATIVE_NAME = "x-session-manager"
-ALTERNATIVE_LINK = "${bindir}/x-session-manager"
-ALTERNATIVE_PATH = "${bindir}/matchbox-session"
-ALTERNATIVE_PRIORITY = "10"
-
EXTRA_OECONF = " --enable-startup-notification \
--disable-xrm \
--enable-expat \
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
index 5550dc2b89..ef9cf761f7 100644
--- a/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
@@ -12,7 +12,7 @@ DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification ex
SRCREV = "f4394eaed475de6e627d373c5b35ee2cf87072e3"
PV = "1.2+git${SRCPV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager;protocol=git \
file://configure_fix.patch;maxrev=1818 \
@@ -20,12 +20,7 @@ SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager;protocol=git \
S = "${WORKDIR}/git"
-inherit autotools pkgconfig update-alternatives
-
-ALTERNATIVE_NAME = "x-session-manager"
-ALTERNATIVE_LINK = "${bindir}/x-session-manager"
-ALTERNATIVE_PATH = "${bindir}/matchbox-session"
-ALTERNATIVE_PRIORITY = "10"
+inherit autotools pkgconfig
FILES_${PN} = "${bindir}/* \
${datadir}/matchbox \
diff --git a/meta/recipes-graphics/mini-x-session/mini-x-session_0.1.bb b/meta/recipes-graphics/mini-x-session/mini-x-session_0.1.bb
index 3818d16a3d..981865090b 100644
--- a/meta/recipes-graphics/mini-x-session/mini-x-session_0.1.bb
+++ b/meta/recipes-graphics/mini-x-session/mini-x-session_0.1.bb
@@ -16,7 +16,7 @@ inherit update-alternatives
ALTERNATIVE_NAME = "x-session-manager"
ALTERNATIVE_LINK = "${bindir}/x-session-manager"
ALTERNATIVE_PATH = "${bindir}/mini-x-session"
-ALTERNATIVE_PRIORITY = "10"
+ALTERNATIVE_PRIORITY = "50"
do_install() {
install -d ${D}/${bindir}