aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2012-11-15 11:17:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-24 15:12:07 +0000
commitba151faad47e6874b295ebd9699ce154bc4ff741 (patch)
tree6f3df9d48199da0d34aaa4d17febe493bad98053
parent7f26794dc9f2e78ee8aed1e23752acb709345c6f (diff)
downloadopenembedded-core-contrib-ba151faad47e6874b295ebd9699ce154bc4ff741.tar.gz
curl: eliminate forced setting of -g0 when compiling
Do not invoke CURL_SET_COMPILER_DEBUG_OPTS in configure.ac. This will allow debug options set in our CFLAGS to be used. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-support/curl/curl/configure_ac.patch11
-rw-r--r--meta/recipes-support/curl/curl_7.26.0.bb7
2 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl/configure_ac.patch b/meta/recipes-support/curl/curl/configure_ac.patch
new file mode 100644
index 0000000000..98d83871f1
--- /dev/null
+++ b/meta/recipes-support/curl/curl/configure_ac.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -281,7 +281,7 @@ dnl ************************************
+
+ CURL_CHECK_COMPILER
+ CURL_SET_COMPILER_BASIC_OPTS
+-CURL_SET_COMPILER_DEBUG_OPTS
++dnl CURL_SET_COMPILER_DEBUG_OPTS
+ CURL_SET_COMPILER_OPTIMIZE_OPTS
+ CURL_SET_COMPILER_WARNING_OPTS
+
diff --git a/meta/recipes-support/curl/curl_7.26.0.bb b/meta/recipes-support/curl/curl_7.26.0.bb
index 9a0e7ce27e..fef247c5d1 100644
--- a/meta/recipes-support/curl/curl_7.26.0.bb
+++ b/meta/recipes-support/curl/curl_7.26.0.bb
@@ -8,11 +8,16 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e66
DEPENDS = "zlib gnutls"
DEPENDS_class-native = "zlib-native openssl-native"
DEPENDS_class-nativesdk = "nativesdk-zlib"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch"
+# curl likes to set -g0 in CFLAGS, so we stop it
+# from mucking around with debug options
+#
+SRC_URI += " file://configure_ac.patch"
+
SRC_URI[md5sum] = "bfa80f01b3d300359cfb4d409b6136a3"
SRC_URI[sha256sum] = "fced262f16eb6bfcdcea15e04a7905ffcb5ff04b14a19ca35b9df86d6720d26a"