aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-05-21 16:18:41 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-30 10:45:33 +0100
commitb1ea93143a473f006b31ab22f88baf41661971a7 (patch)
treec4946d0524abc8b5a64804a660d093acedc85e82
parent5879e0d3a2b3a6d000e33cadf4407c38ae1eb1ab (diff)
downloadopenembedded-core-contrib-b1ea93143a473f006b31ab22f88baf41661971a7.tar.gz
shadow-utils-native: remove unnecessary alternatives
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
index 61fccbac26..fece9c6f50 100644
--- a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
@@ -45,25 +45,4 @@ do_install_append() {
# Now we don't have a mail system. Disable mail creation for now.
sed -i 's:/bin/bash:/bin/sh:g' ${D}${sysconfdir}/default/useradd
sed -i '/^CREATE_MAIL_SPOOL/ s:^:#:' ${D}${sysconfdir}/default/useradd
-
- install -d ${D}${sbindir} ${D}${base_sbindir} ${D}${base_bindir}
- for i in passwd chfn newgrp chsh ; do
- mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}
- done
-
- mv ${D}${sbindir}/chpasswd ${D}${sbindir}/chpasswd.${PN}
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/passwd passwd passwd.${PN} 200
- update-alternatives --install ${sbindir}/chpasswd chpasswd chpasswd.${PN} 200
- update-alternatives --install ${bindir}/chfn chfn chfn.${PN} 200
- update-alternatives --install ${bindir}/newgrp newgrp newgrp.${PN} 200
- update-alternatives --install ${bindir}/chsh chsh chsh.${PN} 200
-}
-
-pkg_prerm_${PN} () {
- for i in passwd chpasswd chfn newgrp chsh ; do
- update-alternatives --remove $i $i.${PN}
- done
}