aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZumeng Chen <zumeng.chen@windriver.com>2012-01-16 23:46:58 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-17 14:53:04 +0000
commitb054921f7dd59519a896a4e1a5f40965d4abd87e (patch)
tree7685d9d522d58b2a46f5c46884cf4e09fec3d265
parent4733cd6501e5d39b4229c3da79529d6a3ae844f6 (diff)
downloadopenembedded-core-contrib-b054921f7dd59519a896a4e1a5f40965d4abd87e.tar.gz
lttng-modules: Update to 2.0
This patch intended to integrate the lttng-modules 2.0 package containing the kernel tracer modules. LTTng-modules 2.0 is currently in pre-release (-pre11), so we have to update it when official released. lttng-2.0 supports lttng-modules extra builds, which don't need any patches on Linux kernel vs the previous version of lttng. As described in README of lttng-modules-2.0, so far, it has been tested in the latest kernel on x86 32/64-bit, and powerpc 32-bit, , build tested on ARM. So does yocto kernel, the related tests on qemux86 and qemuppc has been validated and a build test on qemuarm passed too with this patcheset. Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com>
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch41
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb27
2 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
new file mode 100644
index 0000000000..aa24171f31
--- /dev/null
+++ b/meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
@@ -0,0 +1,41 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+lttng-modules: replace KERNELDIR with KERNEL_SRC
+
+Since lttng-modules uses the default way of module.bbclass to
+build and install lttng-modules, we do this replacement for
+it as-is.
+
+Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com>
+---
+ Makefile | 7 +++----
+ 1 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 5ac13d7..25caad5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -38,17 +38,16 @@ obj-m += lib/
+ endif
+
+ else
+- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
+ PWD := $(shell pwd)
+ CFLAGS = $(EXTCFLAGS)
+
+ default:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
+
+ modules_install:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
+
+ clean:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
+
+ endif
+--
+1.7.5.4
+
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
new file mode 100644
index 0000000000..5d34c41a34
--- /dev/null
+++ b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
@@ -0,0 +1,27 @@
+SECTION = "devel"
+SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
+DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1eb086682a7c65a45acd9bcdf6877b3e \
+ file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
+ file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
+
+DEPENDS = virtual/kernel
+
+inherit module
+
+SRCREV = "4d3e89e379fc66480d729abe8daa5c86eb585400"
+PV = "2.0.pre11+git${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
+ file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
+
+export INSTALL_MOD_DIR="kernel/lttng-modules"
+
+S = "${WORKDIR}/git"
+
+# Due to liburcu not building for MIPS currently this recipe needs to
+# be limited also.
+# So here let us first suppport x86/arm/powerpc platforms now.
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'