aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-02-14 14:12:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-14 22:26:12 +0000
commit9987f210e3faf31bfeab35ae56606c8a577b3aa0 (patch)
tree34ab1c80547b65310b0feda2bed28f8219010ad0
parentcc7352ed990b1bdd26203a4d3b21286280ac26c5 (diff)
downloadopenembedded-core-contrib-9987f210e3faf31bfeab35ae56606c8a577b3aa0.tar.gz
remake: do not create po files
The 'make update' was using wget to get the gmo and other gnu files from upstream, since need to work cleanly in a non-networked or proxy environment this does not so well. Remove the list of languages from the LINGUAS file. [YOCTO #3745] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
index 7e9857e972..42c4d4879f 100644
--- a/meta/recipes-devtools/remake/remake_git.bb
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -13,13 +13,11 @@ DEPENDS += "readline"
PROVIDES += "make"
do_configure_prepend() {
+ # remove the default LINGUAS since we are not going to generate languages
+ rm po/LINGUAS
+ touch po/LINGUAS
# create config.rpath which required by configure.ac
autopoint || touch config.rpath
}
-do_compile_prepend() {
- # updating .po and other gnu build files
- make update
-}
-
BBCLASSEXTEND = "native"