aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-01-12 16:42:33 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:57 +0000
commit96e513f758f962a4e5d84ffc5f24dd8ab46944c1 (patch)
tree3e8de5c5857d20284649c7b5ae2caf6caa56d595
parent3e052919c9307ba73a1db0f705b7dc1a677cb80f (diff)
downloadopenembedded-core-contrib-96e513f758f962a4e5d84ffc5f24dd8ab46944c1.tar.gz
systemtap: new package
Add systemtap, a general-purpose script-directed dynamic tracing and performance analysis tool for Linux. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc1
-rw-r--r--meta/recipes-core/tasks/task-poky-tools.bb1
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb28
3 files changed, 30 insertions, 0 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index b2609c5c19..87c3136a80 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -165,6 +165,7 @@ SRCREV_pn-screenshot ??= "292"
SRCREV_pn-settings-daemon ??= "2059"
SRCREV_pn-swabber-native ??= "a0792390c5d6d5a5bade7ab155c80eef3f30fa52"
SRCREV_pn-sysprof ??= "38a6af1f0a45e528fd2842983da71e0f23c70d6a"
+SRCREV_pn-systemtap ??= "4ab3a1863bf4f472acae7a809bf2b38d91658aa8"
SRCREV_pn-table ??= "4b267533ce16656cba4104fc39dc12709c1bdddf"
SRCREV_pn-tasks ??= "ea52d46d691c5fce4473ea4e24a35411381f3a65"
TRACECMDREV ?= "6c696cec3f264a9399241b6e648f58bc97117d49"
diff --git a/meta/recipes-core/tasks/task-poky-tools.bb b/meta/recipes-core/tasks/task-poky-tools.bb
index 60a95f9f9d..c23a3fe52d 100644
--- a/meta/recipes-core/tasks/task-poky-tools.bb
+++ b/meta/recipes-core/tasks/task-poky-tools.bb
@@ -51,6 +51,7 @@ RRECOMMENDS_task-poky-tools-profile = "\
kernel-module-oprofile \
blktrace \
sysprof \
+ systemtap \
"
# exmap-console
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
new file mode 100644
index 0000000000..f28c946a18
--- /dev/null
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "SystemTap - script-directed dynamic tracing and performance analysis tool for Linux"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "elfutils"
+
+PR = r0
+PV = "1.4+git${SRCPV}"
+
+SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git \
+ "
+
+EXTRA_OECONF = "--prefix=${D} --with-libelf=${STAGING_DIR_TARGET} --without-rpm \
+ ac_cv_file__usr_include_nss=no \
+ ac_cv_file__usr_include_nss3=no \
+ ac_cv_file__usr_include_nspr=no \
+ ac_cv_file__usr_include_nspr4=no \
+ ac_cv_file__usr_include_avahi_client=no \
+ ac_cv_file__usr_include_avahi_common=no "
+
+SRC_URI[md5sum] = "cb202866ed704c44a876d041f788bdee"
+SRC_URI[sha256sum] = "8ffe35caec0d937bd23fd78a3a8d94b58907cc0de0330b35e38f9f764815c459"
+
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuppc|emenlow|crownbay|atom-pc|n450)"
+
+S = "${WORKDIR}/git"
+
+inherit autotools