aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-04-12 21:43:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-13 16:00:04 +0100
commit7c95d554c431451f975e1e5d0336d1fb7d0ce7ae (patch)
tree5d051fe3996f9035e0c1ebd7fe1175242afcfac2
parentf960da1b48bafb3ccdd58222fe9fc12c1bb6ed9b (diff)
downloadopenembedded-core-contrib-7c95d554c431451f975e1e5d0336d1fb7d0ce7ae.tar.gz
eglibc: fix perl path in target scripts on fedora 17 alpha
fedora 17 has /usr/bin/perl as well as /bin/perl, which results in the perl path set in thetarget perl scripts as /bin/perl While we install perl on target at ${bindir}/perl i.e. /usr/bin/perl Hence the target perl scripts are broken when build is done on fedora 17. Work around the issue by providing cached value of perl path to eglibc This fixes bug [YOCTO #2286] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc2
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb2
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb2
3 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index 8e3fe503b8..66934477b6 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -54,3 +54,5 @@ do_configure_prepend() {
GLIBC_ADDONS ?= "ports,nptl,libidn"
SDK_GLIBC_ADDONS ?= "ports,nptl,libidn"
GLIBC_ADDONS_virtclass-nativesdk = "${SDK_GLIBC_ADDONS}"
+
+CACHED_CONFIGUREVARS = "ac_cv_path_PERL=${bindir}/perl"
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index 872767e85d..c1b6844934 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "15508"
DEPENDS += "gperf-native"
-PR = "r23"
+PR = "r24"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_13"
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index dd04378fb4..d52fe2de5a 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "17386"
DEPENDS += "gperf-native"
-PR = "r3"
+PR = "r4"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_15"