aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-09-22 12:30:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-24 11:23:46 +0100
commit6bb6ca6164b6b5f082fe05c30974463c2aa1c170 (patch)
tree59488bed695b6039c61e8680c4892c30376f593e
parent3dffb9f577b794e8b78fb884adf9a15c45965bc4 (diff)
downloadopenembedded-core-contrib-6bb6ca6164b6b5f082fe05c30974463c2aa1c170.tar.gz
qemu-native: fix build on hosts without libX11 installed
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.2.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_1.2.0.bb b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
index 7091f6d97f..191ee48e06 100644
--- a/meta/recipes-devtools/qemu/qemu_1.2.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
@@ -17,7 +17,7 @@ SRC_URI = "\
SRC_URI[md5sum] = "78eb1e984f4532aa9f2bdd3c127b5b61"
SRC_URI[sha256sum] = "c8b84420d9f4869397f84cad2dabd9a475b7723d619a924a873740353e9df936"
-PR = "r1"
+PR = "r2"
SRC_URI_append_virtclass-nativesdk = "\
file://relocatable_sdk.patch \
@@ -29,4 +29,8 @@ do_configure_prepend_virtclass-nativesdk() {
sed -i 's/-lX11//g' Makefile.target
fi
}
+do_configure_prepend_virtclass-native() {
+ # Undo the -lX11 added by linker-flags.patch, don't assume that host has libX11 installed
+ sed -i 's/-lX11//g' Makefile.target
+}