aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-30 23:54:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-31 11:52:27 +0100
commit69bd94173294c1ae2cf5e300ada7116e99a5b0c7 (patch)
treeaa7c595d48956e0e1d3e711267b86bd17ba96995
parenta834ab8a6d53cae504fa112a89bab93d726539ec (diff)
downloadopenembedded-core-contrib-69bd94173294c1ae2cf5e300ada7116e99a5b0c7.tar.gz
glib-2.0-nativesdk: Fix build on ubuntu 11.10
When you have a distro which has older version of glib-2.0 installed then it does not have compile_resources installed which essentially glib-2.0 nativesdk is looking for on build host. So like in a cross build we disable the configure check which will force it to build an internal copy and use it. This problem may not be seen on newer distros like ubuntu 12.04 since they have newer version of glib-2.0 installed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
index 988494b426..932c9466f5 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
@@ -22,6 +22,7 @@ SRC_URI[sha256sum] = "a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b1
SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
BBCLASSEXTEND = "native nativesdk"
+CACHED_CONFIGUREVARS_virtclass-nativesdk = "ac_cv_path_GLIB_COMPILE_RESOURCES=/bin/true"
do_configure_prepend() {
sed -i -e "s:TEST_PROGS += gdbus-serialization::g" ${S}/gio/tests/Makefile.am
sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in