aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2011-03-14 14:43:26 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-16 13:38:02 +0000
commit50c61a4fe2f4ad65d6934a3ec3799e6a64709ed3 (patch)
tree48354605709d62f7a6baaecdfeaa22eb5efc01ac
parenta7c2c126e4ab12e4ba13cd4cfad70b6556739bc5 (diff)
downloadopenembedded-core-contrib-50c61a4fe2f4ad65d6934a3ec3799e6a64709ed3.tar.gz
documentation/adt-manual/Makefile: Initial Makefile
These edits take the Makefile from the version I copied over from the Kernel manual to create the initial version for the ADT Manual. Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
-rw-r--r--documentation/adt-manual/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/documentation/adt-manual/Makefile b/documentation/adt-manual/Makefile
index dcfcb92312..ec19bce9cd 100644
--- a/documentation/adt-manual/Makefile
+++ b/documentation/adt-manual/Makefile
@@ -14,7 +14,7 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
all: html pdf tarball
pdf:
- ../tools/poky-docbook-to-pdf kernel-manual.xml ../template
+ ../tools/poky-docbook-to-pdf adt-manual.xml ../template
##
# These URI should be rewritten by your distribution's xml catalog to
@@ -23,16 +23,16 @@ pdf:
html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
-# xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
- xsltproc $(XSLTOPTS) -o kernel-manual.html yocto-project-kernel-manual-customization.xsl kernel-manual.xml
+# xsltproc $(XSLTOPTS) -o adt-manual.html $(XSL_XHTML_URI) adt-manual.xml
+ xsltproc $(XSLTOPTS) -o adt-manual.html adt-manual-customization.xsl adt-manual.xml
tarball: html
- tar -cvzf kernel-manual.tgz kernel-manual.html style.css figures/kernel-title.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
+ tar -cvzf adt-manual.tgz adt-manual.html style.css figures/adt-title.png figures/yocto-project-transp.png
validate:
- xmllint --postvalid --xinclude --noout kernel-manual.xml
+ xmllint --postvalid --xinclude --noout adt-manual.xml
-OUTPUTS = kernel-manual.tgz kernel-manual.html kernel-manual.pdf
+OUTPUTS = adt-manual.tgz adt-manual.html adt-manual.pdf
SOURCES = *.png *.xml *.css
publish: