aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-08-26 10:43:15 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 13:29:50 +0100
commit4c86c99be8d3771a9f2b20ebead387d584d3d57d (patch)
treece02aed0b6729a492ada01b550d58ff366a944cc
parent98bd03a50833903e3fca3958af3a448fc8dcf3a9 (diff)
downloadopenembedded-core-contrib-4c86c99be8d3771a9f2b20ebead387d584d3d57d.tar.gz
readline: Split GPLv2 version from shared inc file
Do not share common inc file with GPLv3 version of recipe Fix the issue of multiple provider warning Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-rw-r--r--meta/packages/readline/readline.inc1
-rw-r--r--meta/packages/readline/readline_5.2.bb34
2 files changed, 32 insertions, 3 deletions
diff --git a/meta/packages/readline/readline.inc b/meta/packages/readline/readline.inc
index 966def992d..35bc7ed946 100644
--- a/meta/packages/readline/readline.inc
+++ b/meta/packages/readline/readline.inc
@@ -10,7 +10,6 @@ LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS += "ncurses"
-RPROVIDES_${PN} += "readline"
SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz \
file://configure-fix.patch \
diff --git a/meta/packages/readline/readline_5.2.bb b/meta/packages/readline/readline_5.2.bb
index 10f88ce196..a62345c45e 100644
--- a/meta/packages/readline/readline_5.2.bb
+++ b/meta/packages/readline/readline_5.2.bb
@@ -1,5 +1,35 @@
-require readline.inc
+DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
+command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
+additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
+lines, and perform csh-like history expansion on previous commands."
+SECTION = "libs"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f"
-PR = "r5"
+
+DEPENDS += "ncurses"
+PRIORITY = "optional"
+
+PR = "r6"
+
+SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz \
+ file://configure-fix.patch \
+ file://acinclude.m4"
+
+S = "${WORKDIR}/${BPN}-${PV}"
+
+inherit autotools
+
+LEAD_SONAME = "libreadline.so"
+
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_install_append () {
+ # Make install doesn't properly install these
+ oe_libinstall -so -C shlib libhistory ${D}${libdir}
+ oe_libinstall -so -C shlib libreadline ${D}${libdir}
+}
+
+BBCLASSEXTEND = "native nativesdk"