aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-31 11:19:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-31 12:44:38 +0100
commit3490772a87eda8d86027d4150a7c1b94c9ee282a (patch)
tree75175c91395d87f1caa9c8644b946f1578ba3000
parent86a41a27681dc4cb0f4bf35e35013c9ecdad4c35 (diff)
downloadopenembedded-core-contrib-3490772a87eda8d86027d4150a7c1b94c9ee282a.tar.gz
sysvinit: make pidof usuable in a standalone setting
Currently it's a symlink to killall5: $ dpkg-deb -c sysvinit-pidof_2.88dsf-r1_armv7a.ipk | grep pidof lrwxrwxrwx root/root 0 2011-05-27 11:05 ./bin/pidof.sysvinit -> /sbin/killall5 The point of the pidof subpackage was to have a pidof without needing sysvinit, this restores that behaviour. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
index 7d5e9366ec..2cb650eab6 100644
--- a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
@@ -5,7 +5,7 @@ SECTION = "base"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://COPYRIGHT;endline=15;md5=349c872e0066155e1818b786938876a4"
-PR = "r1"
+PR = "r3"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.
@@ -47,9 +47,11 @@ ALTERNATIVE_PRIORITY = "50"
PACKAGES =+ "sysvinit-pidof sysvinit-sulogin"
FILES_${PN} += "${base_sbindir}/* ${base_bindir}/*"
-FILES_sysvinit-pidof = "${base_bindir}/pidof.sysvinit"
+FILES_sysvinit-pidof = "${base_bindir}/pidof.sysvinit ${base_sbindir}/killall5"
FILES_sysvinit-sulogin = "${base_sbindir}/sulogin"
+RDEPENDS_${PN} += "sysvinit-pidof"
+
CFLAGS_prepend = "-D_GNU_SOURCE "
export LCRYPT = "-lcrypt"
EXTRA_OEMAKE += "'base_bindir=${base_bindir}' \