aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-11-28 14:11:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 13:48:22 +0000
commit22dfc7d5738a20f015d9de693f0c2accfa685560 (patch)
tree88eacdcd40c8d273189c3cd1726101a757db8dc1
parentb3f99e01c249c34d6083eec3159d5ba6b54df97f (diff)
downloadopenembedded-core-contrib-22dfc7d5738a20f015d9de693f0c2accfa685560.tar.gz
eglibc: Move compile with optimization handling to common code
The optimisation handling code is not version specific, so move the fix code to the .inc. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc11
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb11
2 files changed, 11 insertions, 11 deletions
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index 3d136bf8d7..1e041977de 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -8,6 +8,17 @@ PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TCBOOTSTRAP}"
+# eglibc can't be built without optimization, if someone tries to compile an
+# entire image as -O0, we override it with -O2 here and give a note about it.
+def get_optimization(d):
+ selected_optimization = d.getVar("SELECTED_OPTIMIZATION", True)
+ if base_contains("SELECTED_OPTIMIZATION", "-O0", "x", "", d) == "x":
+ bb.note("eglibc can't be built with -O0, -O2 will be used instead.")
+ return selected_optimization.replace("-O0", "-O2")
+ return selected_optimization
+
+SELECTED_OPTIMIZATION := "${@get_optimization(d)}"
+
# siteconfig.bbclass runs configure which needs a working compiler
# For the compiler to work we need a working libc yet libc isn't
# in the sysroots directory at this point. This means the libc.so
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 71bcc308b3..aa9256cdc1 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -87,17 +87,6 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
-# eglibc can't be built without optimization, if someone tries to compile an
-# entire image as -O0, we override it with -O2 here and give a note about it.
-def get_optimization(d):
- selected_optimization = d.getVar("SELECTED_OPTIMIZATION", True)
- if base_contains("SELECTED_OPTIMIZATION", "-O0", "x", "", d) == "x":
- bb.note("eglibc can't be built with -O0, -O2 will be used instead.")
- return selected_optimization.replace("-O0", "-O2")
- return selected_optimization
-
-SELECTED_OPTIMIZATION := "${@get_optimization(d)}"
-
do_unpack_append() {
bb.build.exec_func('do_move_ports', d)
}