aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-24 14:55:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-01 18:32:27 +0100
commit22988891bd66f4e65ba47b7e5eb261da281e6cba (patch)
treef66f10b4a65d10e90fde035d20398abdcf714e64
parentac9d1c23ba47455eb99d8c2c661fc70583d7c02b (diff)
downloadopenembedded-core-contrib-22988891bd66f4e65ba47b7e5eb261da281e6cba.tar.gz
dtc: Cleanup and update recipe
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-kernel/dtc/dtc-native.inc3
-rw-r--r--meta/recipes-kernel/dtc/dtc-native_git.bb5
-rw-r--r--meta/recipes-kernel/dtc/dtc.inc8
-rw-r--r--meta/recipes-kernel/dtc/dtc/remove_space_opt.patch2
-rw-r--r--meta/recipes-kernel/dtc/dtc_git.bb15
-rw-r--r--meta/recipes-kernel/dtc/dtc_git.inc8
6 files changed, 21 insertions, 20 deletions
diff --git a/meta/recipes-kernel/dtc/dtc-native.inc b/meta/recipes-kernel/dtc/dtc-native.inc
deleted file mode 100644
index 1da7004316..0000000000
--- a/meta/recipes-kernel/dtc/dtc-native.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-require dtc.inc
-
-inherit native
diff --git a/meta/recipes-kernel/dtc/dtc-native_git.bb b/meta/recipes-kernel/dtc/dtc-native_git.bb
deleted file mode 100644
index fd5bde5765..0000000000
--- a/meta/recipes-kernel/dtc/dtc-native_git.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
-
-require dtc-native.inc
-require dtc_git.inc
diff --git a/meta/recipes-kernel/dtc/dtc.inc b/meta/recipes-kernel/dtc/dtc.inc
index e068df3c73..cfed15a4c5 100644
--- a/meta/recipes-kernel/dtc/dtc.inc
+++ b/meta/recipes-kernel/dtc/dtc.inc
@@ -2,7 +2,7 @@ SUMMARY = "Device Tree Compiler"
DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
SECTION = "bootloader"
PRIORITY = "optional"
-LICENSE = "GPL"
+LICENSE = "GPL2 | BSD"
DEPENDS = "flex-native bison-native"
inherit autotools
@@ -11,3 +11,9 @@ do_install() {
install -m 0755 -d ${D}${bindir}
install -m 755 dtc ${D}${bindir}/dtc
}
+SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
+ file://fix_for_compilation_with_gcc_4.6.0.patch"
+
+INC_PR = "r0"
+
+S = "${WORKDIR}/git"
diff --git a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
index 805bf58796..8c26deca35 100644
--- a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
+++ b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
@@ -1,5 +1,7 @@
Remove the -Os flag
+Upstream-Status: Inappropriate [configuration]
+
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Index: git/Makefile
===================================================================
diff --git a/meta/recipes-kernel/dtc/dtc_git.bb b/meta/recipes-kernel/dtc/dtc_git.bb
index 1cca32cedb..e010488dd8 100644
--- a/meta/recipes-kernel/dtc/dtc_git.bb
+++ b/meta/recipes-kernel/dtc/dtc_git.bb
@@ -1,7 +1,16 @@
require dtc.inc
-require dtc_git.inc
-LICENSE="GPLv2|BSD"
+
LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
-SRC_URI += " file://remove_space_opt.patch"
+SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
+PV = "1.3.0+git${SRCPV}"
+PR = "${INC_PR}.0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI_PATCH = " file://remove_space_opt.patch"
+SRC_URI_PATCH_virtclass-native = ""
+SRC_URI += "${SRC_URI_PATCH}"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-kernel/dtc/dtc_git.inc b/meta/recipes-kernel/dtc/dtc_git.inc
deleted file mode 100644
index 2400cfe52f..0000000000
--- a/meta/recipes-kernel/dtc/dtc_git.inc
+++ /dev/null
@@ -1,8 +0,0 @@
-SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
- file://fix_for_compilation_with_gcc_4.6.0.patch"
-
-SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
-PV = "1.2.0+git${SRCPV}"
-PR = "r3"
-
-S = "${WORKDIR}/git"