aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-02-29 23:55:00 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-01 15:49:25 +0000
commit14b86a350d07b0da550a7a39886a660210918fbf (patch)
tree9facd366745b0fa429ab11dc9d2a9b39dec36f11
parent983c1264e93d19bc9e605633f224c73e961912ae (diff)
downloadopenembedded-core-contrib-14b86a350d07b0da550a7a39886a660210918fbf.tar.gz
util-linux: Fix build when NLS is disabled
AC_CHECK_DECLS generated defines should be checked with #if not #ifdef Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch24
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.21.bb5
2 files changed, 27 insertions, 2 deletions
diff --git a/meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch b/meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch
new file mode 100644
index 0000000000..545c3a9c7b
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux-2.21/fix_NL_TIME_FIRST_WEEKDAY.patch
@@ -0,0 +1,24 @@
+configure uses AC_CHECK_DECLS to check for _NL_TIME_WEEK_1STDAY
+which means we will get HAVE_DECL__NL_TIME_WEEK_1STDAY
+defined to 1 if symbol is declared, otherwise to 0 in config.h
+
+Therefore we cannot rely on conditionals which check for it
+being defined or not since it always will be defined so correct
+thing is to use #if instead of #ifdef
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: util-linux-2.21/misc-utils/cal.c
+===================================================================
+--- util-linux-2.21.orig/misc-utils/cal.c 2012-02-29 23:41:54.413347665 -0800
++++ util-linux-2.21/misc-utils/cal.c 2012-02-29 23:42:44.573350057 -0800
+@@ -297,7 +297,7 @@
+ * the locale database, which can be overridden with the
+ * -s (Sunday) or -m (Monday) options.
+ */
+-#ifdef HAVE_DECL__NL_TIME_WEEK_1STDAY
++#if HAVE_DECL__NL_TIME_WEEK_1STDAY
+ /*
+ * You need to use 2 locale variables to get the first day of the week.
+ * This is needed to support first_weekday=2 and first_workday=1 for
diff --git a/meta/recipes-core/util-linux/util-linux_2.21.bb b/meta/recipes-core/util-linux/util-linux_2.21.bb
index e21f484b79..744dbaf58b 100644
--- a/meta/recipes-core/util-linux/util-linux_2.21.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.21.bb
@@ -1,5 +1,5 @@
MAJOR_VERSION = "2.21"
-PR = "r1"
+PR = "r2"
require util-linux.inc
# note that `lscpu' is under GPLv3+
@@ -7,7 +7,8 @@ LICENSE_util-linux-lscpu = "GPLv3+"
SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
file://util-linux-ng-2.16-mount_lock_path.patch \
- file://uclibc-__progname-conflict.patch \
+ file://uclibc-__progname-conflict.patch \
+ file://fix_NL_TIME_FIRST_WEEKDAY.patch \
"
SRC_URI[md5sum] = "3c7a26963f3921c1e775a80330321870"