aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Brodkin <alexey.brodkin@synopsys.com>2019-01-11 15:50:14 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 11:21:58 +0000
commit463f10fde9f72d26e89db324ca675bfe597fcc5e (patch)
treec328c008789e579978c7197ab1038d0271cf1981
parent8a75d614a8a1ff72c4af448ac3e1292d0e1d1a79 (diff)
downloadopenembedded-core-contrib-463f10fde9f72d26e89db324ca675bfe597fcc5e.tar.gz
webkitgtk: Enable building for ARC architecture
For that we need 2 things: 1. Disable JIT in JS as it's not supported for ARC. 2. Compile with "-mlong-calls" so relocations with offsets larger than 25 bits are used, otherwise linker fails to link final binaries. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Alexander Kanavin <alex.kanavin@gmail.com> Cc: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.22.5.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.22.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.22.5.bb
index 2e79f739ea..e3579e472b 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.22.5.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.22.5.bb
@@ -69,6 +69,13 @@ EXTRA_OECMAKE = " \
EXTRA_OECMAKE_append_x86 = " -DUSE_GSTREAMER_GL=OFF "
EXTRA_OECMAKE_append_x86-x32 = " -DUSE_GSTREAMER_GL=OFF "
+# Javascript JIT is not supported on ARC
+EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
+# By default 25-bit "medium" calls are used on ARC
+# which is not enough for binaries larger than 32 MiB
+CFLAGS_append_arc = " -mlong-calls"
+CXXFLAGS_append_arc = " -mlong-calls"
+
# Javascript JIT is not supported on powerpc
EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "