summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-10-17 19:03:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-18 10:38:57 +0100
commitd31212bcfe9232e7f6ac9efb4fad0be175a9ca00 (patch)
treecc85413abf29a658e8901be7979914b39c2506c0
parent6cc99d48c57cb22104980d0d758540e06cb7b80d (diff)
downloadopenembedded-core-contrib-d31212bcfe9232e7f6ac9efb4fad0be175a9ca00.tar.gz
systemtap: fix QA issue
ERROR: systemtap-4.0-r0 do_package: QA Issue: systemtap: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/stap-exporter.service Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. systemtap: 4 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 78a82efc2c..904ecdd106 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -27,6 +27,8 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
inherit autotools gettext pkgconfig distutils3-base systemd
+SYSTEMD_SERVICE_${PN} = "stap-exporter.service"
+
do_configure_prepend () {
# Improve reproducibility for c++ object files
reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}"