summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2018-11-07 12:59:22 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-09 15:27:04 +0000
commit17d5574f05384edeb5c80ada2724fff4a1c3c94b (patch)
tree7ac0058d51a9b4baaa1768c36f188bdf70b7f3a6
parent2012d6b076fc833864a0254d56d78536314a6799 (diff)
downloadopenembedded-core-contrib-17d5574f05384edeb5c80ada2724fff4a1c3c94b.tar.gz
valgrind: drop mips n32 support
valgrind for qemumips64 multilib builds fails to configure for libn32 with the error: configure:6190: checking for 32 bit build support ... fatal error: bits/long-double-32.h: No such file or directory It seems that the toolchain is producing: tmp-glibc/sysroots-components/mips64-n32/libn32-glibc/usr/include/bits/long-double-n32.h Until the toolchain problem is resolved, skip valgrind for libn32. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb1
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.14.0.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
index 4ec1f9284f..33d9c09a66 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -63,6 +63,7 @@ VALGRIND_armeb = ""
VALGRIND_aarch64 = ""
VALGRIND_riscv64 = ""
VALGRIND_linux-gnux32 = ""
+VALGRIND_linux-gnun32 = ""
RDEPENDS_${PN} = "\
${PROFILETOOLS} \
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb
index 7f0a93f6f8..97e58a446a 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb
@@ -54,6 +54,7 @@ COMPATIBLE_HOST_linux-muslx32 = 'null'
# Disable for some MIPS variants
COMPATIBLE_HOST_mipsarchr6 = 'null'
+COMPATIBLE_HOST_linux-gnun32 = 'null'
inherit autotools ptest multilib_header