aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-01-10 14:31:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-14 09:11:27 +0000
commit6d56f14a7276f076dfe625bc4d2c16a6a4635153 (patch)
tree33eaf613486d3d38ba0ff1292afd18962ae8262f
parent61444fd318c266800ef8fb308a5c16f90d5e3a3f (diff)
downloadopenembedded-core-contrib-6d56f14a7276f076dfe625bc4d2c16a6a4635153.tar.gz
perf: conditionalise pythonnative and perlnative inherits
Only inherit these classes (and so, add perl-native and python-native to DEPENDS) if the scripting PACKAGECONFIG is actually enabled. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index bb943ecd1c..1bad6f4e9b 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -35,9 +35,10 @@ do_configure[depends] += "virtual/kernel:do_shared_workdir"
PROVIDES = "virtual/perf"
-inherit linux-kernel-base kernel-arch pythonnative
+inherit linux-kernel-base kernel-arch
# needed for building the tools/perf Python bindings
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'pythonnative', '', d)}
inherit python-dir
export PYTHON_SITEPACKAGES_DIR
@@ -47,7 +48,8 @@ export WERROR = "0"
do_populate_lic[depends] += "virtual/kernel:do_patch"
# needed for building the tools/perf Perl binding
-inherit perlnative cpan-base
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perlnative', '', d)}
+inherit cpan-base
# Env var which tells perl if it should use host (no) or target (yes) settings
export PERLCONFIGTARGET = "${@is_target(d)}"
export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}/CORE"