summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2022-01-13 04:18:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-14 09:25:27 +0000
commit427ca80eb4ea6c607b00028adcc9302e29db1368 (patch)
tree911ffb359170e66fb052a5b0c120fd1069af5c3a
parent1653e0bd6d26be67a9fd49392d82cf854706bc7b (diff)
downloadopenembedded-core-contrib-427ca80eb4ea6c607b00028adcc9302e29db1368.tar.gz
systemd: Avoid a Python deprecation warning
This avoids the following warning: WARNING: .../meta/recipes-core/systemd/systemd_250.1.bb: Var <do_install>:1: DeprecationWarning: invalid escape sequence \$ seen when doing `devtool finish --force-patch-refresh systemd meta`. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_250.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-core/systemd/systemd_250.1.bb b/meta/recipes-core/systemd/systemd_250.1.bb
index b05905b764..4dd668833a 100644
--- a/meta/recipes-core/systemd/systemd_250.1.bb
+++ b/meta/recipes-core/systemd/systemd_250.1.bb
@@ -297,8 +297,9 @@ do_install() {
# this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
# for existence else it fails
- if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ]; then
- ${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf', d)}
+ if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ] &&
+ ! ${@bb.utils.contains('PACKAGECONFIG', 'networkd', 'true', 'false', d)}; then
+ echo 'd /run/systemd/netif/links 0755 root root -' >>${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf
fi
if ! ${@bb.utils.contains('PACKAGECONFIG', 'resolved', 'true', 'false', d)}; then
echo 'L! ${sysconfdir}/resolv.conf - - - - ../run/systemd/resolve/resolv.conf' >>${D}${exec_prefix}/lib/tmpfiles.d/etc.conf