aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2015-11-10 21:16:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 08:07:55 +0000
commitad8a2ca46075a7ea236d6db9da963dc0040d2206 (patch)
tree4c8818af9bb94a5c64c1cdfea5d8eaeae67c7475
parentf4c16f53af27ad459e77ae7f43e7bf1bad70645a (diff)
downloadopenembedded-core-contrib-ad8a2ca46075a7ea236d6db9da963dc0040d2206.tar.gz
blkspace: fix ldflags for iowatcher
This quiets a GNU_HASH warning. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/blktrace/blktrace/ldflags.patch23
1 files changed, 18 insertions, 5 deletions
diff --git a/meta/recipes-kernel/blktrace/blktrace/ldflags.patch b/meta/recipes-kernel/blktrace/blktrace/ldflags.patch
index 037d161340..dea1aa2028 100644
--- a/meta/recipes-kernel/blktrace/blktrace/ldflags.patch
+++ b/meta/recipes-kernel/blktrace/blktrace/ldflags.patch
@@ -9,11 +9,6 @@ http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id
aed463414e2e2bf8ca44ba54ee5973e7ed599e57
Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
----
- Makefile | 11 ++++++-----
- btreplay/Makefile | 3 ++-
- btt/Makefile | 3 ++-
- 3 files changed, 10 insertions(+), 7 deletions(-)
--- git.orig/Makefile
+++ git/Makefile
@@ -91,3 +86,21 @@ Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
ifneq ($(wildcard .depend),)
include .depend
+--- git.orig/iowatcher/Makefile
++++ git/iowatcher/Makefile
+@@ -1,5 +1,6 @@
+ C = gcc
+ CFLAGS = -Wall -O0 -g -W
++LDFLAGS =
+ ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+ PROGS = iowatcher
+@@ -19,7 +20,7 @@ all: $(ALL)
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ iowatcher: blkparse.o plot.o main.o tracers.o mpstat.o fio.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm
++ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm $(LDFLAGS)
+
+ depend:
+ @$(CC) -MM $(ALL_CFLAGS) *.c 1> .depend