aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-04-15 18:26:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:48:28 +0100
commit1229f5dbd48362c7717ac31b631aefce2dccbdc1 (patch)
tree0e681abdf34f53d2cb846bd0dab55b4364921d5b
parent2f5ab5632e9c7be5fef5fcb57c52dbec7d0880f9 (diff)
downloadopenembedded-core-contrib-1229f5dbd48362c7717ac31b631aefce2dccbdc1.tar.gz
jpeg: add link libjpeg.so.62 for LSB library test
LSB test just test whether libjpeg.so.62 exists, and no more use of it. So just make link to pass library check. Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-core/jpeg/jpeg_8b.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8b.bb b/meta/recipes-core/jpeg/jpeg_8b.bb
index 8e2c24dd21..78fabf1efd 100644
--- a/meta/recipes-core/jpeg/jpeg_8b.bb
+++ b/meta/recipes-core/jpeg/jpeg_8b.bb
@@ -14,7 +14,7 @@ PRIORITY = "required"
DEPENDS = "libtool-cross"
DEPENDS_virtclass-native = "libtool-native"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
file://debian-libjpeg7_7-1.diff;patch=1"
@@ -45,3 +45,14 @@ DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs fo
FILES_jpeg-tools = "${bindir}/*"
BBCLASSEXTEND = "native"
+
+pkg_postinst_${PN}_poky-lsb () {
+ if [ "$D" = "" ]; then
+ if [ ! -e ${libdir}/libjpeg.so.62 ]; then
+ JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
+ ln -sf `basename $JPEG` ${libdir}/libjpeg.so.62
+ fi
+ else
+ exit 1
+ fi
+}