aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-15 12:07:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-15 15:46:21 +0100
commit087a680429efa713a98fbb89f927b046fe07f87c (patch)
treeeb4a671956ade18810798d5b6cdda849d6527587
parentbcd68f11e479e8a3a95793ab2ed65202c0f71d84 (diff)
downloadopenembedded-core-contrib-087a680429efa713a98fbb89f927b046fe07f87c.tar.gz
allarch: Drop various problematic allarch usages
In each of these cases allarch is used where the package in question has a dependency on things which are not allach and change when MACHINE is changed. This leads to a rebuild of the package each time MACHINE is switched and the sstate checksum changes. The dependencies in question are not suited be being marked as ABISAFE. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/udev/udev-extraconf_1.0.bb2
-rw-r--r--meta/recipes-devtools/devel-config/anjuta-remote-run.bb2
-rw-r--r--meta/recipes-devtools/devel-config/distcc-config.bb2
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root.bb2
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb2
-rw-r--r--meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb2
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb2
7 files changed, 2 insertions, 12 deletions
diff --git a/meta/recipes-core/udev/udev-extraconf_1.0.bb b/meta/recipes-core/udev/udev-extraconf_1.0.bb
index ea95a60067..fd9a333fe6 100644
--- a/meta/recipes-core/udev/udev-extraconf_1.0.bb
+++ b/meta/recipes-core/udev/udev-extraconf_1.0.bb
@@ -4,8 +4,6 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-inherit allarch
-
PR = "r8"
SRC_URI = " \
diff --git a/meta/recipes-devtools/devel-config/anjuta-remote-run.bb b/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
index 51fdf9ecac..b9cded74a8 100644
--- a/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
+++ b/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
@@ -15,5 +15,3 @@ do_install() {
PACKAGES = "${PN}"
RDEPENDS_${PN} = "dbus rsync"
-inherit allarch
-
diff --git a/meta/recipes-devtools/devel-config/distcc-config.bb b/meta/recipes-devtools/devel-config/distcc-config.bb
index 8deaa66589..c9c024dde9 100644
--- a/meta/recipes-devtools/devel-config/distcc-config.bb
+++ b/meta/recipes-devtools/devel-config/distcc-config.bb
@@ -21,5 +21,3 @@ do_install() {
}
RDEPENDS_${PN} = "distcc"
-
-inherit allarch
diff --git a/meta/recipes-devtools/devel-config/nfs-export-root.bb b/meta/recipes-devtools/devel-config/nfs-export-root.bb
index 4d9f6dd5aa..5fa8cb3c0f 100644
--- a/meta/recipes-devtools/devel-config/nfs-export-root.bb
+++ b/meta/recipes-devtools/devel-config/nfs-export-root.bb
@@ -15,5 +15,3 @@ do_install() {
}
RDEPENDS_${PN} = "packagegroup-core-nfs-server"
-
-inherit allarch
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
index a34825ab19..c99521f9b6 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
@@ -12,7 +12,7 @@ RDEPENDS_${PN} = "fontconfig-utils"
PR = "r4"
PE = "1"
-inherit allarch fontcache
+inherit fontcache
FONT_PACKAGES = "${PN}"
diff --git a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
index ccd865ce4d..75f78a2745 100644
--- a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
+++ b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
PR = "r7"
RDEPENDS_${PN} = "fontconfig-utils"
-inherit allarch fontcache
+inherit fontcache
FONT_PACKAGES = "${PN}"
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
index 49de5a3218..2df1347860 100644
--- a/meta/recipes-graphics/x11-common/x11-common_0.1.bb
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -9,8 +9,6 @@ SRC_URI = "file://etc \
S = "${WORKDIR}"
-inherit allarch
-
do_install() {
cp -R ${S}/etc ${D}${sysconfdir}
chmod -R 755 ${D}${sysconfdir}