summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-09-03 21:31:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-05 22:18:12 +0100
commit5e6174c58d5e3a95eccee773b6670242cb9ab8f4 (patch)
tree44707a91a8ab3c701c7f98e38952126f36fa4353
parent4864167ad4ed4c57e49f2aa5e7c58383bddb052b (diff)
downloadopenembedded-core-contrib-5e6174c58d5e3a95eccee773b6670242cb9ab8f4.tar.gz
kea: no need to depend on kea-native
kea-msg-compiler is only needed if you alter the messages and the generated sources need to be rebuilt. When this is the case, there are better ways to build kea-msg-compiler that don't involve building all of Kea. Don't depend on kea-native, remove BBCLASSEXTEND=native, and the target overrides. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/kea/kea_1.7.7.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/meta/recipes-connectivity/kea/kea_1.7.7.bb b/meta/recipes-connectivity/kea/kea_1.7.7.bb
index e25f8e6fb0..c69a180833 100644
--- a/meta/recipes-connectivity/kea/kea_1.7.7.bb
+++ b/meta/recipes-connectivity/kea/kea_1.7.7.bb
@@ -5,8 +5,6 @@ SECTION = "connectivity"
LICENSE = "MPL-2.0 & Apache-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa"
-DEPENDS += "kea-native"
-
SRC_URI = "\
http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
file://0001-remove-AC_TRY_RUN.patch \
@@ -32,16 +30,14 @@ DEBUG_OPTIMIZATION_append_mipsel = " -O"
BUILD_OPTIMIZATION_remove_mipsel = " -Og"
BUILD_OPTIMIZATION_append_mipsel = " -O"
-do_configure_prepend_class-target() {
- mkdir -p ${B}/src/lib/log/compiler/
- ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
+do_configure_prepend() {
# replace abs_top_builddir to avoid introducing the build path
# don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in
}
-do_install_append_class-target() {
+do_install_append() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
@@ -62,6 +58,4 @@ PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost"
FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
FILES_${PN} += "${libdir}/hooks/*.so"
-BBCLASSEXTEND += "native"
-
PARALLEL_MAKEINST = ""