summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-09-06 14:51:59 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-07 13:08:27 +0100
commitfb17b46e202cc08277d3eeb34872067c73a6bfbc (patch)
tree8a54f5c52f75ca6ffdc05a2189e8528efa1ee0b8
parent802c67c7c27011812d690c41347b38481cdab2e9 (diff)
downloadopenembedded-core-contrib-fb17b46e202cc08277d3eeb34872067c73a6bfbc.tar.gz
libevent: add granularity to ptest log
The libevent ptest used to report only a global pass or a fail result. Count individual PASS, FAIL, SKIP results. The SKIP results now include tests that are disabled in the libevent code. libevent's ptest output did not comply with the automake-style output "result: testname", and reported a FAIL status at the end of the test run if any of the libevent tests failed. This patch makes the log consistent with the automake style: PASS: http/cancel_by_host_no_ns PASS: http/cancel_inactive_server PASS: http/cancel_by_host_no_ns_inactive_server SKIPPED: http/cancel_by_host_server_timeout SKIPPED: http/cancel_server_timeout and provides a summary as follows: === Test Summary === TOTAL: 316 PASSED: 300 FAILED: 0 SKIPPED: 16 DURATION: 87 END: /usr/lib/libevent/ptest Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libevent/libevent/run-ptest34
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.11.bb3
2 files changed, 25 insertions, 12 deletions
diff --git a/meta/recipes-support/libevent/libevent/run-ptest b/meta/recipes-support/libevent/libevent/run-ptest
index 0241851c70..080806dea9 100644
--- a/meta/recipes-support/libevent/libevent/run-ptest
+++ b/meta/recipes-support/libevent/libevent/run-ptest
@@ -1,18 +1,28 @@
#!/bin/sh
-fail=0
+# run-ptest - 'ptest' test infrastructure shell script that
+# wraps the libevent test scripts
+#
+# Trevor Gamblin <trevor.gamblin@windriver.com>
+###############################################################
+LIBEVENTLIB=@libdir@/libevent
+LOG="${LIBEVENTLIB}/ptest/libevent_ptest_$(date +%Y%m%d-%H%M%S).log"
+
+cd ${LIBEVENTLIB}/ptest
+
for test in ./test/*
do
- $test
- if [ $? -ne 0 ]
- then
- fail=1
- fi
+ $test 2>&1| sed -e '/OK/ s/^/PASS: / ; /FAILED/ s/^/FAIL: / ; /SKIPPED/ s/^/SKIP: / ; /DISABLED/ s/^/SKIP: /' | cut -f1,2 -d ':' | tee -a ${LOG}
done
-if [ $fail -eq 0 ]
-then
- echo "PASS: libevent"
-else
- echo "FAIL: libevent"
-fi
+passed=`grep PASS ${LOG}|wc -l`
+failed=`grep FAIL ${LOG}|wc -l`
+skipped=`grep -E SKIP ${LOG}|wc -l`
+all=$((passed + failed + skipped))
+
+( echo "=== Test Summary ==="
+ echo "TOTAL: ${all}"
+ echo "PASSED: ${passed}"
+ echo "FAILED: ${failed}"
+ echo "SKIPPED: ${skipped}"
+) | tee -a ${LOG}
diff --git a/meta/recipes-support/libevent/libevent_2.1.11.bb b/meta/recipes-support/libevent/libevent_2.1.11.bb
index 1e18f0ab2c..f005ab8bda 100644
--- a/meta/recipes-support/libevent/libevent_2.1.11.bb
+++ b/meta/recipes-support/libevent/libevent_2.1.11.bb
@@ -43,4 +43,7 @@ do_install_ptest() {
do
install -m 0755 $file ${D}${PTEST_PATH}/test
done
+
+ # handle multilib
+ sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
}