aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:36:53 +0100
commitb7c00d3290ea99547f04ae2bcb4c8dcb969888c0 (patch)
treeba8e9972b3247fc31c1c8e0d8cae5af3b2f11f6b
parentbb2ecb102f30d5165c4e47adadfe5d052c6a06ce (diff)
downloadopenembedded-core-contrib-b7c00d3290ea99547f04ae2bcb4c8dcb969888c0.tar.gz
python-git: Upgrade from 1.0.2 to 2.0.5
Move checksums into the relevant recipes as currently python-git and python3-git are at different versions - RB. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-git.inc5
-rw-r--r--meta/recipes-devtools/python/python-git_2.0.5.bb (renamed from meta/recipes-devtools/python/python-git_1.0.2.bb)4
-rw-r--r--meta/recipes-devtools/python/python3-git_1.0.2.bb3
3 files changed, 7 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python-git.inc b/meta/recipes-devtools/python/python-git.inc
index 72632b7a8c..4cb53e789e 100644
--- a/meta/recipes-devtools/python/python-git.inc
+++ b/meta/recipes-devtools/python/python-git.inc
@@ -8,10 +8,7 @@ SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
-SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "d92d96a8da0fc77cf141d3e16084e094"
-SRC_URI[sha256sum] = "85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84"
+SRC_URI = "https://files.pythonhosted.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
diff --git a/meta/recipes-devtools/python/python-git_1.0.2.bb b/meta/recipes-devtools/python/python-git_2.0.5.bb
index 5ca7713dc9..de4c76ed1a 100644
--- a/meta/recipes-devtools/python/python-git_1.0.2.bb
+++ b/meta/recipes-devtools/python/python-git_2.0.5.bb
@@ -1,8 +1,10 @@
require python-git.inc
+SRC_URI[md5sum] = "f4f60f269fb5f6a332c653a5bc015239"
+SRC_URI[sha256sum] = "20f3c90fb8a11edc52d363364fb0a116a410c7b7bdee24a433712b5413d1028e"
+
DEPENDS = "python-gitdb"
inherit setuptools
RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold python-unixadmin"
-
diff --git a/meta/recipes-devtools/python/python3-git_1.0.2.bb b/meta/recipes-devtools/python/python3-git_1.0.2.bb
index 6620444a86..034708e851 100644
--- a/meta/recipes-devtools/python/python3-git_1.0.2.bb
+++ b/meta/recipes-devtools/python/python3-git_1.0.2.bb
@@ -1,5 +1,8 @@
require python-git.inc
+SRC_URI[md5sum] = "d92d96a8da0fc77cf141d3e16084e094"
+SRC_URI[sha256sum] = "85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84"
+
DEPENDS = "python3-gitdb"
inherit setuptools3