summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-19 11:20:31 +0000
committerSteve Sakoman <steve@sakoman.com>2022-03-07 07:05:18 -1000
commit56f57c70fb87beb9a7181df8cb5e7a4a0b5a184a (patch)
treea9f619d568d71e58d644677040ff9807d199d0cb
parent6b899f694ec57bb3c6254d59ac5c51378579c014 (diff)
downloadopenembedded-core-contrib-56f57c70fb87beb9a7181df8cb5e7a4a0b5a184a.tar.gz
systemd: Ensure uid/gid ranges are set deterministically
meson.build will fall back to greping /etc/login.defs for values of these if they're not set. Different distros set them (Centos 7/8 does, Ubuntu does not) so output was not deterministic. Avoid this by setting to the default values. We now match the vaules from login.defs from shadow. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 77a6ac0ac266d71e4fe67fd332662081f30cd7bf) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/systemd/systemd_244.5.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_244.5.bb b/meta/recipes-core/systemd/systemd_244.5.bb
index 66446e2a7c..a648272bc0 100644
--- a/meta/recipes-core/systemd/systemd_244.5.bb
+++ b/meta/recipes-core/systemd/systemd_244.5.bb
@@ -216,6 +216,8 @@ EXTRA_OEMESON += "-Dnobody-user=nobody \
-Drootlibdir=${rootlibdir} \
-Drootprefix=${rootprefix} \
-Ddefault-locale=C \
+ -Dsystem-uid-max=999 \
+ -Dsystem-gid-max=999 \
"
# Hardcode target binary paths to avoid using paths from sysroot