aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2016-03-21 11:01:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-23 14:24:25 +0000
commit8cc5e36cd7978186d5ea1fe8af2f2bd6b3df8885 (patch)
tree8efd7b89048843b9b308ff058becb09ab7e5b8f0
parentce14964d99741f1a4579bae18da5013498c365fd (diff)
downloadopenembedded-core-contrib-8cc5e36cd7978186d5ea1fe8af2f2bd6b3df8885.tar.gz
python(3): Disable tkinter
* restore changes from: http://git.openembedded.org/openembedded-core/commit/?id=53ae544cfdac22c82af452b8c7ebe6664296bd9b * which were shamelessly removed in upgrade to 2.7.9: http://git.openembedded.org/openembedded-core/commit/?id=d4ad95f0d5f08891637c644e85b09da9c4585059 and then spread to python3 as well * fixes following issues reported by test-dependencies WARN: python3: python3-tkinter rdepends on glibc, but it isn't a build dependency? WARN: python3: python3-tkinter rdepends on libpython3, but it isn't a build dependency? WARN: python3: python3-tkinter rdepends on tcl-lib, but it isn't a build dependency? WARN: python: python-tkinter rdepends on glibc, but it isn't a build dependency? WARN: python: python-tkinter rdepends on libpython2, but it isn't a build dependency? WARN: python: python-tkinter rdepends on tcl-lib, but it isn't a build dependency? and following QA warnings in normal builds: python-2.7.11: python-tkinter rdepends on tcl-lib, but it isn't a build dependency, missing tcl in DEPENDS or PACKAGECONFIG? [build-deps] python-2.7.11: /usr/lib/python2.7/lib-dynload/_tkinter.so contained in package python-tkinter requires libtk8.6.so, but no providers found in RDEPENDS_python-tkinter? [file-rdeps] python3-3.5.1: python3-tkinter rdepends on tcl-lib, but it isn't a build dependency, missing tcl in DEPENDS or PACKAGECONFIG? [build-deps] python3-3.5.1: /usr/lib/python3.5/lib-dynload/_tkinter.cpython-35m-arm-linux-gnueabi.so contained in package python3-tkinter requires libtk8.6.so, but no providers found in RDEPENDS_python3-tkinter? [file-rdeps] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python/avoid_warning_about_tkinter.patch14
-rw-r--r--meta/recipes-devtools/python/python3/avoid_warning_about_tkinter.patch14
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/avoid_warning_about_tkinter.patch b/meta/recipes-devtools/python/python/avoid_warning_about_tkinter.patch
index 208c57c822..3347321fde 100644
--- a/meta/recipes-devtools/python/python/avoid_warning_about_tkinter.patch
+++ b/meta/recipes-devtools/python/python/avoid_warning_about_tkinter.patch
@@ -4,6 +4,7 @@ Avoid a warning by not adding this module to missing variable.
Upstream-Status: Inappropriate [distribution]
+Also simply disable the tk module since its not in DEPENDS.
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Index: Python-2.7.2/setup.py
@@ -23,3 +24,16 @@ Index: Python-2.7.2/setup.py
return missing
+diff --git Python-3.5.1.orig/setup.py Python-3.5.1/setup.py
+index b4633b9..d7588c0 100644
+--- Python-3.5.1.orig/setup.py
++++ Python-3.5.1/setup.py
+@@ -1536,7 +1536,7 @@ class PyBuildExt(build_ext):
+ self.extensions.extend(exts)
+
+ # Call the method for detecting whether _tkinter can be compiled
+- self.detect_tkinter(inc_dirs, lib_dirs)
++ # self.detect_tkinter(inc_dirs, lib_dirs)
+
+ # tkinter module will not be avalaible as yocto
+ # doesn't have tk integrated (yet)
diff --git a/meta/recipes-devtools/python/python3/avoid_warning_about_tkinter.patch b/meta/recipes-devtools/python/python3/avoid_warning_about_tkinter.patch
index 208c57c822..3347321fde 100644
--- a/meta/recipes-devtools/python/python3/avoid_warning_about_tkinter.patch
+++ b/meta/recipes-devtools/python/python3/avoid_warning_about_tkinter.patch
@@ -4,6 +4,7 @@ Avoid a warning by not adding this module to missing variable.
Upstream-Status: Inappropriate [distribution]
+Also simply disable the tk module since its not in DEPENDS.
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Index: Python-2.7.2/setup.py
@@ -23,3 +24,16 @@ Index: Python-2.7.2/setup.py
return missing
+diff --git Python-3.5.1.orig/setup.py Python-3.5.1/setup.py
+index b4633b9..d7588c0 100644
+--- Python-3.5.1.orig/setup.py
++++ Python-3.5.1/setup.py
+@@ -1536,7 +1536,7 @@ class PyBuildExt(build_ext):
+ self.extensions.extend(exts)
+
+ # Call the method for detecting whether _tkinter can be compiled
+- self.detect_tkinter(inc_dirs, lib_dirs)
++ # self.detect_tkinter(inc_dirs, lib_dirs)
+
+ # tkinter module will not be avalaible as yocto
+ # doesn't have tk integrated (yet)