aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-18 13:33:48 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-20 09:20:05 +0000
commit18dbd28d638ee4b50de5a7a1aca00f3277fdb42e (patch)
tree38353db7d8f52577af43271f4dccf6dddb8e217c
parentffea660e794b8a6215ddb9a34bce00c461dc9170 (diff)
downloadopenembedded-core-contrib-18dbd28d638ee4b50de5a7a1aca00f3277fdb42e.tar.gz
strace: drop unnecessary dependency on acl
The dependency on acl was removed from strace prior to the v4.10 release, so it's no longer necessary to add a configure option to allow acl to be disabled. http://sourceforge.net/p/strace/code/ci/681452b0f854833d4bd443fcd9bb0bab2b46339f Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/strace/strace/strace-add-configure-options.patch24
-rw-r--r--meta/recipes-devtools/strace/strace_4.10.bb3
2 files changed, 3 insertions, 24 deletions
diff --git a/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch b/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
index e48e4b31b9..a3f8ec463d 100644
--- a/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
+++ b/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
@@ -1,4 +1,4 @@
-Add options "aio" and "acl" to enable/disable libaio and acl support.
+Add option "aio" to enable/disable libaio support.
Upstream-Status: Pending
@@ -12,26 +12,7 @@ diff --git a/configure.ac b/configure.ac
index e73958c..9099370 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -270,6 +270,18 @@ AC_CHECK_HEADERS(m4_normalize([
- sys/vfs.h
- sys/xattr.h
- ]))
-+
-+AC_ARG_ENABLE([acl],
-+ [AS_HELP_STRING([--enable-acl], [turn on acl support])],
-+ [case $enableval in
-+ yes)
-+ AC_CHECK_HEADERS([sys/acl.h])
-+ ;;
-+ no) ;;
-+ *) AC_MSG_ERROR([bad value $enableval for aio option]) ;;
-+ esac]
-+)
-+
- AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
- [], [], [#include <stddef.h>
- #include <sys/socket.h>
-@@ -745,6 +757,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes; then
+@@ -745,6 +745,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes;
fi
AC_SUBST(dl_LIBS)
@@ -54,4 +35,3 @@ index e73958c..9099370 100644
dnl stack trace with libunwind
--
1.9.1
-
diff --git a/meta/recipes-devtools/strace/strace_4.10.bb b/meta/recipes-devtools/strace/strace_4.10.bb
index 20b7e3d0a5..fe250b771c 100644
--- a/meta/recipes-devtools/strace/strace_4.10.bb
+++ b/meta/recipes-devtools/strace/strace_4.10.bb
@@ -21,12 +21,11 @@ inherit autotools ptest bluetooth
RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
PACKAGECONFIG_class-target ??= "\
- libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ libaio \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
"
PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
-PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"