summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan.schmidt@huawei.com>2021-03-04 20:35:40 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-06 22:36:34 +0000
commit8c4981e740c0e630200dbc77c9e3dfd3e43b790b (patch)
treec264dcd02f12860034aef05b12bc35fd703f133f
parent51ca329ea9cd51b699545bae2cf2a6a02f70a887 (diff)
downloadopenembedded-core-contrib-8c4981e740c0e630200dbc77c9e3dfd3e43b790b.tar.gz
systemd-conf: do not ask for DHCP if configured on kernel command line
In cases where we configure the IP address and more on the kernel command line with ip= we should not ask for DHCP with systemd-networkd later on. We have such a setup with our runqemu script. With this match in place we can also deploy this unit on qemu systems. Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd-conf/wired.network1
-rw-r--r--meta/recipes-core/systemd/systemd-conf_247.3.bb3
2 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-core/systemd/systemd-conf/wired.network b/meta/recipes-core/systemd/systemd-conf/wired.network
index 09367edb10..e7b69970d6 100644
--- a/meta/recipes-core/systemd/systemd-conf/wired.network
+++ b/meta/recipes-core/systemd/systemd-conf/wired.network
@@ -1,6 +1,7 @@
[Match]
Type=ether
KernelCommandLine=!nfsroot
+KernelCommandLine=!ip
[Network]
DHCP=yes
diff --git a/meta/recipes-core/systemd/systemd-conf_247.3.bb b/meta/recipes-core/systemd/systemd-conf_247.3.bb
index 944b56ff82..ea35e83f4f 100644
--- a/meta/recipes-core/systemd/systemd-conf_247.3.bb
+++ b/meta/recipes-core/systemd/systemd-conf_247.3.bb
@@ -29,9 +29,6 @@ do_install() {
# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52
do_install_append_qemuall() {
install -D -m0644 ${WORKDIR}/system.conf-qemuall ${D}${systemd_unitdir}/system.conf.d/01-${PN}.conf
-
- # Do not install wired.network for qemu bsps
- rm -rf ${D}${systemd_unitdir}/network
}
PACKAGE_ARCH = "${MACHINE_ARCH}"