aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-06 17:26:36 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-08 10:54:46 +0000
commit98ba7ba8c5bc091f5cc590299f1a636c9b8dc1f5 (patch)
treedf52019c0bb3b0f44686d594601ef33e347dea69
parent02714c105426b0d687620913c1a7401b386428b6 (diff)
downloadopenembedded-core-contrib-98ba7ba8c5bc091f5cc590299f1a636c9b8dc1f5.tar.gz
python: make the python 3.x version of 2to3 utility the default one
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python/python2-manifest.json2
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb3
2 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python/python2-manifest.json b/meta/recipes-devtools/python/python/python2-manifest.json
index 81f1c24f97..eb52e862ab 100644
--- a/meta/recipes-devtools/python/python/python2-manifest.json
+++ b/meta/recipes-devtools/python/python/python2-manifest.json
@@ -109,7 +109,7 @@
"core"
],
"files": [
- "${bindir}/2to3",
+ "${bindir}/2to3*",
"${libdir}/python2.7/lib2to3"
]
},
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index f462d08725..8df1dfd1ba 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -131,6 +131,9 @@ do_install() {
if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'bdb', d)}" ]; then
rm -rf ${D}/${libdir}/python${PYTHON_MAJMIN}/bsddb
fi
+
+ # Python 3.x version of 2to3 is now the default
+ mv ${D}/${bindir}/2to3 ${D}/${bindir}/2to3-${PYTHON_MAJMIN}
}
do_install_append_class-nativesdk () {