aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-12-02 16:09:24 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-11 17:21:43 +0000
commit443ce32b63f756f3f938ef16d665aa347cd8f556 (patch)
tree1ebf4c3f87e93d92d65b056dd2fa87b7b1c581bc
parent9a36dcdb9b48b56e5dc95928b17ff9b0591736f7 (diff)
downloadopenembedded-core-contrib-443ce32b63f756f3f938ef16d665aa347cd8f556.tar.gz
kern-tools: fix processing for no branch meta-data
Lernel meta-data that has patches, but no branches, can trigger an error due to no branch specific patch queue. This error then cascades to more issues since the tools are using a named file in /tmp to store and display error messages to the user. We fix both issues though the following kern tools tweaks: commit bd9e1d6c9b0a34ff3e19a06999aaf57ffadfd04c Author: Bruce Ashfield <bruce.ashfield@windriver.com> Date: Fri Dec 2 13:09:40 2016 -0500 scc: use mktemp for consolidated output capture To provide useful error messages the tools dump pre-processed files and messages to a temporary file. If multiple users are doing builds, this means they either race, or can have permissions issues. By creating the temporary file via mktemp, we avoid both issues. (We also make sure to clean these up on exit, or /tmp will get polluted quickly). commit a287da4bfe0b4acb8f2b0627bd8e7abd1a1dde26 Author: Bruce Ashfield <bruce.ashfield@windriver.com> Date: Fri Dec 2 13:08:08 2016 -0500 patch: do not assume a branch specific patch queue is needed When processing input files per-branch and global patch queues are generated. If the meta-data has not created any branches in the repo, no branch specific queue is required. The tools assumed that one is always valid, and hence would throw a non-zero exit code and stop processing. By testing for a named per-branch queue, we avoid this issue. (From OE-Core rev: 0fd7da7375f0dcc59b56791fd482de557507c04c) (From OE-Core rev: 6bc941a2a8e83e2db409af50ad77a0932e3ffe28) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 88b1aee729..0f8a786176 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=a6c2fa8aef1b
DEPENDS = "git-native"
-SRCREV = "b36f6f9a5695f2084b83823393e13ca42284bed9"
+SRCREV = "bd9e1d6c9b0a34ff3e19a06999aaf57ffadfd04c"
PR = "r12"
PV = "0.2+git${SRCPV}"