aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-06-04 21:06:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-02 23:06:13 +0100
commitd70678477f142eb90c6bba6631e7485d6fe20fbf (patch)
tree0df43fc40fd77d0c286b129451d93d462d43a7b9
parenteda3a2282b768ce50fa3c719b4f3b692071a498b (diff)
downloadopenembedded-core-contrib-d70678477f142eb90c6bba6631e7485d6fe20fbf.tar.gz
libpciaccess: Upgrade to 0.13.4
Drop upstreamed patch backport portablility fixes from upstream Add a fix to not use io function on ARM they dont work Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess/0001-Include-config.h-before-anything-else-in-.c.patch187
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess/0002-Fix-quoting-issue.patch34
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess/0003-linux_sysfs.c-Include-limits.h-for-PATH_MAX.patch32
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess/0004-Don-t-include-sys-io.h-on-arm.patch28
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch17
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess_0.13.3.bb16
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess_0.13.4.bb21
7 files changed, 302 insertions, 33 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess/0001-Include-config.h-before-anything-else-in-.c.patch b/meta/recipes-graphics/xorg-lib/libpciaccess/0001-Include-config.h-before-anything-else-in-.c.patch
new file mode 100644
index 0000000000..e92fc0d95d
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libpciaccess/0001-Include-config.h-before-anything-else-in-.c.patch
@@ -0,0 +1,187 @@
+From b14696a55796e739624bbda4f772427032efff2a Mon Sep 17 00:00:00 2001
+From: Julien Cristau <jcristau@debian.org>
+Date: Sun, 26 Apr 2015 15:20:57 +0200
+Subject: [PATCH 1/4] Include config.h before anything else in *.c
+
+Debian bug#749008 <https://bugs.debian.org/749008>
+
+Reported-by: Michael Tautschnig <mt@debian.org>
+Signed-off-by: Julien Cristau <jcristau@debian.org>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+Upstream-Status: Backport
+
+ src/common_capability.c | 3 +++
+ src/common_init.c | 3 +++
+ src/common_interface.c | 3 +++
+ src/common_io.c | 3 +++
+ src/common_iterator.c | 3 +++
+ src/common_map.c | 3 +++
+ src/common_vgaarb_stub.c | 3 +++
+ src/linux_devmem.c | 5 +++--
+ src/openbsd_pci.c | 3 +++
+ src/solx_devfs.c | 3 +++
+ src/x86_pci.c | 4 +++-
+ 11 files changed, 33 insertions(+), 3 deletions(-)
+
+diff --git a/src/common_capability.c b/src/common_capability.c
+index 488743d..15d395d 100644
+--- a/src/common_capability.c
++++ b/src/common_capability.c
+@@ -31,6 +31,9 @@
+ *
+ * \author Ian Romanick <idr@us.ibm.com>
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <stdio.h>
+diff --git a/src/common_init.c b/src/common_init.c
+index b1c0c3e..f7b59bd 100644
+--- a/src/common_init.c
++++ b/src/common_init.c
+@@ -28,6 +28,9 @@
+ *
+ * \author Ian Romanick <idr@us.ibm.com>
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <errno.h>
+diff --git a/src/common_interface.c b/src/common_interface.c
+index 59778cf..cb95e90 100644
+--- a/src/common_interface.c
++++ b/src/common_interface.c
+@@ -28,6 +28,9 @@
+ *
+ * \author Ian Romanick <idr@us.ibm.com>
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <string.h>
+diff --git a/src/common_io.c b/src/common_io.c
+index f5c9e45..e9586ad 100644
+--- a/src/common_io.c
++++ b/src/common_io.c
+@@ -22,6 +22,9 @@
+ * Author:
+ * Adam Jackson <ajax@redhat.com>
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <string.h>
+diff --git a/src/common_iterator.c b/src/common_iterator.c
+index ccf656d..2beb180 100644
+--- a/src/common_iterator.c
++++ b/src/common_iterator.c
+@@ -28,6 +28,9 @@
+ *
+ * \author Ian Romanick <idr@us.ibm.com>
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <string.h>
+diff --git a/src/common_map.c b/src/common_map.c
+index 8757151..f1854bb 100644
+--- a/src/common_map.c
++++ b/src/common_map.c
+@@ -21,6 +21,9 @@
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ * DEALINGS IN THE SOFTWARE.
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <sys/types.h>
+ #include <sys/mman.h>
+diff --git a/src/common_vgaarb_stub.c b/src/common_vgaarb_stub.c
+index 9394273..c1708f6 100644
+--- a/src/common_vgaarb_stub.c
++++ b/src/common_vgaarb_stub.c
+@@ -23,6 +23,9 @@
+ * OTHER DEALINGS IN THE SOFTWARE.
+ *
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdio.h>
+ #include "pciaccess.h"
+diff --git a/src/linux_devmem.c b/src/linux_devmem.c
+index 10e3bde..0d0567c 100644
+--- a/src/linux_devmem.c
++++ b/src/linux_devmem.c
+@@ -32,8 +32,9 @@
+ *
+ * \author Ian Romanick <idr@us.ibm.com>
+ */
+-
+-#define _GNU_SOURCE
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <string.h>
+diff --git a/src/openbsd_pci.c b/src/openbsd_pci.c
+index 4d1b5cd..b8ce318 100644
+--- a/src/openbsd_pci.c
++++ b/src/openbsd_pci.c
+@@ -13,6 +13,9 @@
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <sys/param.h>
+ #include <sys/ioctl.h>
+diff --git a/src/solx_devfs.c b/src/solx_devfs.c
+index f572393..cf96467 100644
+--- a/src/solx_devfs.c
++++ b/src/solx_devfs.c
+@@ -25,6 +25,9 @@
+ /*
+ * Solaris devfs interfaces
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ #include <stdlib.h>
+ #include <strings.h>
+diff --git a/src/x86_pci.c b/src/x86_pci.c
+index 49c1cab..32daa04 100644
+--- a/src/x86_pci.c
++++ b/src/x86_pci.c
+@@ -18,8 +18,10 @@
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+-#define _GNU_SOURCE
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+--
+2.1.4
+
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess/0002-Fix-quoting-issue.patch b/meta/recipes-graphics/xorg-lib/libpciaccess/0002-Fix-quoting-issue.patch
new file mode 100644
index 0000000000..16d69a82a4
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libpciaccess/0002-Fix-quoting-issue.patch
@@ -0,0 +1,34 @@
+From 765e0a38cb8c40f8865af5cb356ffe6039ffb08f Mon Sep 17 00:00:00 2001
+From: Thomas Klausner <wiz@NetBSD.org>
+Date: Sun, 22 Mar 2015 21:38:23 +0100
+Subject: [PATCH 2/4] Fix quoting issue.
+
+m4 has '[]' as quoting characters, so if we want '[]' to
+end up in the configure script, we need to quote them again.
+
+Reported by Greg Troxel <gdt@ir.bbn.com>.
+
+Signed-off-by: Thomas Klausner <wiz@NetBSD.org>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+Upstream-Status: Backport
+
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index e67e9e1..888330b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -76,7 +76,7 @@ case $host_os in
+ ;;
+ *netbsd*)
+ case $host in
+- *i[3-9]86*)
++ *i[[3-9]]86*)
+ PCIACCESS_LIBS="$PCIACCESS_LIBS -li386"
+ ;;
+ *x86_64*|*amd64*)
+--
+2.1.4
+
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess/0003-linux_sysfs.c-Include-limits.h-for-PATH_MAX.patch b/meta/recipes-graphics/xorg-lib/libpciaccess/0003-linux_sysfs.c-Include-limits.h-for-PATH_MAX.patch
new file mode 100644
index 0000000000..f513c8e59c
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libpciaccess/0003-linux_sysfs.c-Include-limits.h-for-PATH_MAX.patch
@@ -0,0 +1,32 @@
+From 6bd2f7f92eae713663f4e13f6e2cb23526607b8c Mon Sep 17 00:00:00 2001
+From: Felix Janda <felix.janda@posteo.de>
+Date: Fri, 1 May 2015 16:36:50 +0200
+Subject: [PATCH 3/4] linux_sysfs.c: Include <limits.h> for PATH_MAX
+
+Fixes compilation with musl libc.
+
+Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+Signed-off-by: Felix Janda <felix.janda@posteo.de>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+Upstream-Status: Backport
+
+ src/linux_sysfs.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/linux_sysfs.c b/src/linux_sysfs.c
+index 50d94cf..3f95e53 100644
+--- a/src/linux_sysfs.c
++++ b/src/linux_sysfs.c
+@@ -45,6 +45,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <sys/mman.h>
+ #include <dirent.h>
+ #include <errno.h>
+--
+2.1.4
+
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess/0004-Don-t-include-sys-io.h-on-arm.patch b/meta/recipes-graphics/xorg-lib/libpciaccess/0004-Don-t-include-sys-io.h-on-arm.patch
new file mode 100644
index 0000000000..f532858244
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libpciaccess/0004-Don-t-include-sys-io.h-on-arm.patch
@@ -0,0 +1,28 @@
+From b6df5202306bd71158b482f25ca2e6919645d4dd Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 4 Jun 2015 20:55:06 -0700
+Subject: [PATCH 4/4] Don't include sys/io.h on arm
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ src/linux_sysfs.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/linux_sysfs.c b/src/linux_sysfs.c
+index 3f95e53..1e3aad3 100644
+--- a/src/linux_sysfs.c
++++ b/src/linux_sysfs.c
+@@ -50,7 +50,7 @@
+ #include <dirent.h>
+ #include <errno.h>
+
+-#if defined(__i386__) || defined(__x86_64__) || defined(__arm__)
++#if defined(__i386__) || defined(__x86_64__)
+ #include <sys/io.h>
+ #else
+ #define inb(x) -1
+--
+2.1.4
+
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch b/meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch
deleted file mode 100644
index 498020e534..0000000000
--- a/meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Add missing include file to get definition of PATH_MAX
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Pending
-
-Index: libpciaccess-0.13.3/src/linux_sysfs.c
-===================================================================
---- libpciaccess-0.13.3.orig/src/linux_sysfs.c
-+++ libpciaccess-0.13.3/src/linux_sysfs.c
-@@ -44,6 +44,7 @@
- #include <sys/mman.h>
- #include <dirent.h>
- #include <errno.h>
-+#include <limits.h>
-
- #if defined(__i386__) || defined(__x86_64__) || defined(__arm__)
- #include <sys/io.h>
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.3.bb b/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.3.bb
deleted file mode 100644
index 4a832e8ccb..0000000000
--- a/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.3.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Generic PCI access library for X"
-
-DESCRIPTION = "libpciaccess provides functionality for X to access the \
-PCI bus and devices in a platform-independent way."
-
-require xorg-lib-common.inc
-
-SRC_URI += "file://limits.patch"
-
-LICENSE = "MIT & MIT-style"
-LIC_FILES_CHKSUM = "file://COPYING;md5=277aada5222b9a22fbf3471ff3687068"
-
-SRC_URI[md5sum] = "1f65be5ffc55641c1846c2f41d180d00"
-SRC_URI[sha256sum] = "6cd76ccae4e06eee47d3ead84a118740e9406e2a9b7adc9b08e92c69ce89c2e3"
-
-REQUIRED_DISTRO_FEATURES = ""
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.4.bb b/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.4.bb
new file mode 100644
index 0000000000..ffa6a609f3
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.4.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Generic PCI access library for X"
+
+DESCRIPTION = "libpciaccess provides functionality for X to access the \
+PCI bus and devices in a platform-independent way."
+
+require xorg-lib-common.inc
+
+SRC_URI += "\
+ file://0001-Include-config.h-before-anything-else-in-.c.patch \
+ file://0002-Fix-quoting-issue.patch \
+ file://0003-linux_sysfs.c-Include-limits.h-for-PATH_MAX.patch \
+ file://0004-Don-t-include-sys-io.h-on-arm.patch \
+"
+
+SRC_URI[md5sum] = "ace78aec799b1cf6dfaea55d3879ed9f"
+SRC_URI[sha256sum] = "07f864654561e4ac8629a0ef9c8f07fbc1f8592d1b6c418431593e9ba2cf2fcf"
+
+LICENSE = "MIT & MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=277aada5222b9a22fbf3471ff3687068"
+
+REQUIRED_DISTRO_FEATURES = ""