summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-03 16:49:51 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-04 11:40:51 +0000
commit95983108121c8b96f5659d110498bf2afc6189d9 (patch)
tree27380fbaab21010c978d6252dee245657742b76b
parentc84214ac5a55c5256843365b0108d1392282fced (diff)
downloadopenembedded-core-contrib-95983108121c8b96f5659d110498bf2afc6189d9.tar.gz
perf: Enable debug/source packaging
This was disabled in 2014[1] due to an error message which as far as I can tell, no longer occurs. Having debug information and source files present will make debugging reproducibility issues much easier so remove this line as it appears no longer needed. Fix up a few files which have buildpaths in them to avoid QA warnings and reproducubility issues. [1] OE-Core revision c1b5a262c0201faf2c6bf545d6acb32dfe383ba3 Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 1dff39a17e..2f28d16fba 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -360,6 +360,16 @@ FILES:${PN}-python = " \
"
FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
-
-INHIBIT_PACKAGE_DEBUG_SPLIT="1"
DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
+
+PACKAGESPLITFUNCS =+ "perf_fix_sources"
+
+perf_fix_sources () {
+ for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \
+ util/expr-flex.h util/expr-flex.c; do
+ f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f
+ if [ -e $f ]; then
+ sed -i -e 's#${S}/##g' $f
+ fi
+ done
+}