summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2019-09-13 07:49:10 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-16 09:54:21 +0100
commit88849a0652f1a9cffd5c1b5caae2878b3a438273 (patch)
tree69e1bf013cae7f4ed9764e71e011c5a826c0802e
parent76d3574d17c38d93ba4660bdae5730ac222994d4 (diff)
downloadopenembedded-core-contrib-88849a0652f1a9cffd5c1b5caae2878b3a438273.tar.gz
glibc-testsuite: SkipRecipe if libc is not glibc
To prevent issues with parsing or dependencies, limit this recipe to use only when the libc is glibc (and libc-locale is glibc-locale). Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/glibc/glibc-testsuite_2.30.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc-testsuite_2.30.bb b/meta/recipes-core/glibc/glibc-testsuite_2.30.bb
index 64fa8d87df..657fd4dbc1 100644
--- a/meta/recipes-core/glibc/glibc-testsuite_2.30.bb
+++ b/meta/recipes-core/glibc/glibc-testsuite_2.30.bb
@@ -8,6 +8,13 @@ PROVIDES = ""
# setup depends
INHIBIT_DEFAULT_DEPS = ""
+python () {
+ libc = d.getVar("PREFERRED_PROVIDER_virtual/libc")
+ libclocale = d.getVar("PREFERRED_PROVIDER_virtual/libc-locale")
+ if libc != "glibc" or libclocale != "glibc-locale":
+ raise bb.parse.SkipRecipe("glibc-testsuite requires that virtual/libc is glibc")
+}
+
DEPENDS += "glibc-locale libgcc gcc-runtime"
# remove the initial depends